Booster for WooCommerce - Reflected Cross-Site Scripting
Priority LOW 28Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA.
Summary
The Booster for WooCommerce WordPress plugin before 5.6.3, Booster Plus for WooCommerce WordPress plugin before 6.0.0, Booster Elite for WooCommerce WordPress plugin before 6.0.0 do not escape some URLs and parameters before outputting them back in attributes, leading to Reflected Cross-Site Scripting
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00433 37th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA
Fix Fixed Booster for WooCommerce (Unknown): 5.6.3Booster Plus for WooCommerce (Unknown): 6.0.0+1 more product
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | Booster for WooCommerce | before 5.6.3 | 5.6.3 | Patch available | CNA |
| Unknown | Booster Plus for WooCommerce | before 6.0.0 | 6.0.0 | Patch available | CNA |
| Unknown | Booster Elite for WooCommerce | before 6.0.0 | 6.0.0 | Patch available | CNA |
- Booster for WooCommerce VendorUnknown Affected before 5.6.3 Fixed in 5.6.3 Patch available CNA
- Booster Plus for WooCommerce VendorUnknown Affected before 6.0.0 Fixed in 6.0.0 Patch available CNA
- Booster Elite for WooCommerce VendorUnknown Affected before 6.0.0 Fixed in 6.0.0 Patch available CNA
CPE configurations NVD · 3
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:booster:booster_elite_for_woocommerce:*:*:*:*:*:wordpress:*:* | before 6.0.0 | Vulnerable | pluggabl |
| cpe:2.3:a:booster:booster_for_woocommerce:*:*:*:*:*:wordpress:*:* | before 5.6.3 | Vulnerable | pluggabl |
| cpe:2.3:a:booster:booster_plus_for_woocommerce:*:*:*:*:*:wordpress:*:* | before 6.0.0 | Vulnerable | pluggabl |
- cpe:2.3:a:booster:booster_elite_for_woocommerce:*:*:*:*:*:wordpress:*:* Versions before 6.0.0 Vulnerable ·pluggabl
- cpe:2.3:a:booster:booster_for_woocommerce:*:*:*:*:*:wordpress:*:* Versions before 5.6.3 Vulnerable ·pluggabl
- cpe:2.3:a:booster:booster_plus_for_woocommerce:*:*:*:*:*:wordpress:*:* Versions before 6.0.0 Vulnerable ·pluggabl
Remediation
- Fix · CNA Booster for WooCommerce (Unknown) Fixed in 5.6.3
- Fix · CNA Booster Plus for WooCommerce (Unknown) Fixed in 6.0.0
- Fix · CNA Booster Elite for WooCommerce (Unknown) Fixed in 6.0.0
Timeline
- 2026-10-02 Threatist record created from CVE-2022-4227
- 2026-10-03 Alias added: GHSA-366w-rp6m-qm5x
References
Sources
- CVE-2022-4227 · CVE Program
- CVE-2022-4227 · NVD
- FIRST EPSS
- GHSA-366w-rp6m-qm5x · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences