Custom Field Template < 2.5.8 - Admin+ PHP Object Injection
Priority HIGH 67Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA.
Summary
The Custom Field Template WordPress plugin before 2.5.8 unserialises the content of an imported file, which could lead to PHP object injections issues when a high privilege user import (intentionally or not) a malicious Customizer Styling file and a suitable gadget chain is present on the blog.
Why it matters now
Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.17686 97th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA and NVD
Fix Fixed Custom Field Template (Unknown): 2.5.8
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | Custom Field Template | before 2.5.8 | 2.5.8 | Patch available | CNA |
- Custom Field Template VendorUnknown Affected before 2.5.8 Fixed in 2.5.8 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:wpgogo:custom_field_template:*:*:*:*:*:wordpress:*:* | before 2.5.8 | Vulnerable | Hiroaki Miyashita |
- cpe:2.3:a:wpgogo:custom_field_template:*:*:*:*:*:wordpress:*:* Versions before 2.5.8 Vulnerable ·Hiroaki Miyashita
Remediation
- Fix · CNA Custom Field Template (Unknown) Fixed in 2.5.8
Timeline
- 2026-10-02 Threatist record created from CVE-2022-4324
- 2026-10-03 Alias added: GHSA-482p-fj3c-xcw8
References
More Hiroaki Miyashita Custom Field Template vulnerabilities
- TI-2023-08870 WordPress Custom Field Template Plugin <= 2.5.8 is vulnerable to Cross Site Request Forgery (CSRF) CVSS 3.1HIGH 8.8
- TI-2023-19776 WordPress Custom Field Template Plugin <= 2.5.9 is vulnerable to Cross Site Scripting (XSS) CVSS 3.1HIGH 7.1
- TI-2024-29651 WordPress Custom Field Template plugin <= 2.6.5 - Cross Site Scripting (XSS) vulnerability CVSS 3.1MEDIUM 6.5
- TI-2024-00582 Custom Field Template <= 2.6.1 - Authenticated(Constibutor+) Stored Cross-Site Scripting via Custom Field Name CVSS 3.1MEDIUM 6.4
- TI-2023-06164 Custom Field Template <= 2.6.1 - Authenticated(Contributor+) Stored Cross-Site Scripting via shortcode CVSS 3.1MEDIUM 6.4
- TI-2024-00603 Custom Field Template <= 2.6.1 - Authenticated (Admin+) Stored Cross-Site Scritping CVSS 3.1MEDIUM 4.8
Sources
- CVE-2022-4324 · CVE Program
- CVE-2022-4324 · NVD
- FIRST EPSS
- GHSA-482p-fj3c-xcw8 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences