Read the docs
TI-2022-04121 Aliases CVE-2022-4508GHSA-x7pj-q89m-9php

ConvertKit < 2.0.5 - Contributor+ Stored XSS

Priority MEDIUM 58Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
Required
Attack complexity
Low
Impact type
—
Confidentiality · integrity · availability
Low · Low · None
Fix status
Fixed

Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA.

Summary

The ConvertKit WordPress plugin before 2.0.5 does not validate and escapes some of its shortcode attributes before outputting them back in the page, which could allow users with a role as low as a contributor to perform Stored Cross-Site Scripting attacks, which could be used against high-privilege users such as admins.

Why it matters now

Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00539 45th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA and NVD
Fix Fixed ConvertKit (Unknown): 2.0.5

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
Poc
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
UnknownConvertKitbefore 2.0.52.0.5Patch availableCNA
  • ConvertKit VendorUnknown Affected before 2.0.5 Fixed in 2.0.5 Patch available CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:convertkit:convertkit_-_email_marketing\,_email_newsletter_and_landing_pages:*:*:*:*:*:wordpress:*:*before 2.0.5VulnerableConvertKit
  • cpe:2.3:a:convertkit:convertkit_-_email_marketing\,_email_newsletter_and_landing_pages:*:*:*:*:*:wordpress:*:* Versions before 2.0.5 Vulnerable ·ConvertKit

Remediation

  • Fix · CNA ConvertKit (Unknown) Fixed in 2.0.5

Timeline

  1. 2026-10-02 Threatist record created from CVE-2022-4508
  2. 2026-10-03 Alias added: GHSA-x7pj-q89m-9php

References

  • TI-2023-02193 ConvertKit < 2.2.1 - Reflected XSS CVSS 3.1MEDIUM 6.1
  • TI-2024-20621 WordPress ConvertKit plugin <= 2.4.5 - Email Disclosure in Log File vulnerability CVSS 3.1HIGH 7.5
  • TI-2024-03695 ConvertKit <= 2.4.9 - Missing Authorization CVSS 3.1MEDIUM 5.3

Sources