Auto Upload Images cross site scripting
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- No fix listed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-79.
Summary
A vulnerability has been found in Auto Upload Images up to 3.3.0 and classified as problematic. Affected by this vulnerability is an unknown functionality. The manipulation leads to cross site scripting. The attack can be launched remotely. Upgrading to version 3.3.1 is able to address this issue. The name of the patch is 895770ee93887ec78429c78ffdfb865bee6f9436. It is recommended to upgrade the affected component. The identifier VDB-216481 was assigned to this vulnerability.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | Auto Upload Images | 3.0; 3.1; 3.2; 3.3 | — | No fix listed | CNA |
- Auto Upload Images Vendor— Affected 3.0; 3.1; 3.2; 3.3 Fixed in — No fix listed CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:auto_upload_images_project:auto_upload_images:*:*:*:*:*:wordpress:*:* | before 3.3.1 | Vulnerable | Auto Upload Images Project |
- cpe:2.3:a:auto_upload_images_project:auto_upload_images:*:*:*:*:*:wordpress:*:* Versions before 3.3.1 Vulnerable ·Auto Upload Images Project
Remediation
No fixed version listed by the sources yet.
Timeline
- 2026-10-02 Threatist record created from CVE-2022-4632
- 2026-10-03 Alias added: GHSA-gh77-92x7-j48m
References
More Auto Upload Images Project Auto Upload Images vulnerabilities
- TI-2022-04234 Auto Upload Images Settings setting-page.php cross-site request forgery CVSS 3.1HIGH 8.8
- TI-2022-20879 WordPress Auto Upload Images Plugin <= 3.3 is vulnerable to Cross Site Request Forgery (CSRF) CVSS 3.1MEDIUM 6.1
Sources
- CVE-2022-4632 · CVE Program
- CVE-2022-4632 · NVD
- FIRST EPSS
- GHSA-gh77-92x7-j48m · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences