Read the docs
TI-2022-04234 Aliases CVE-2022-4633GHSA-v4mr-hpp4-m2rj

Auto Upload Images Settings setting-page.php cross-site request forgery

Priority LOW 38CWE-352Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
Required
Attack complexity
Low
Impact type
Tampering
Confidentiality · integrity · availability
High · High · High
Fix status
No fix listed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-352.

Summary

A vulnerability was found in Auto Upload Images up to 3.3.0 and classified as problematic. Affected by this issue is some unknown functionality of the file src/setting-page.php of the component Settings Handler. The manipulation leads to cross-site request forgery. The attack may be launched remotely. Upgrading to version 3.3.1 is able to address this issue. The name of the patch is 895770ee93887ec78429c78ffdfb865bee6f9436. It is recommended to upgrade the affected component. VDB-216482 is the identifier assigned to this vulnerability.

Why it matters now

EPSS 0.00374 31st percentileScored 2026-11-07
Fix No fix listed No fixed version in the sources yet

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
—Auto Upload Images3.0; 3.1; 3.2; 3.3—No fix listedCNA
  • Auto Upload Images Vendor— Affected 3.0; 3.1; 3.2; 3.3 Fixed in — No fix listed CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:auto_upload_images_project:auto_upload_images:*:*:*:*:*:wordpress:*:*before 3.3.1VulnerableAuto Upload Images Project
  • cpe:2.3:a:auto_upload_images_project:auto_upload_images:*:*:*:*:*:wordpress:*:* Versions before 3.3.1 Vulnerable ·Auto Upload Images Project

Remediation

No fixed version listed by the sources yet.

Timeline

  1. 2026-10-02 Threatist record created from CVE-2022-4633
  2. 2026-10-03 Alias added: GHSA-v4mr-hpp4-m2rj

References

  • TI-2022-04233 Auto Upload Images cross site scripting CVSS 3.1MEDIUM 6.1
  • TI-2022-20879 WordPress Auto Upload Images Plugin <= 3.3 is vulnerable to Cross Site Request Forgery (CSRF) CVSS 3.1MEDIUM 6.1

Sources