Print-O-Matic < 2.1.8 - Contributor+ Stored XSS via Shortcode
Priority HIGH 66Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA.
Summary
The Print-O-Matic WordPress plugin before 2.1.8 does not validate and escape some of its shortcode attributes before outputting them back in the page, which could allow users with a role as low as contributor to perform Stored Cross-Site Scripting attacks which could be used against high privilege users such as admins.
Why it matters now
Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00476 41st percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA and NVD
Fix Fixed Print-O-Matic (Unknown): 2.1.8
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- Yes
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | Print-O-Matic | before 2.1.8 | 2.1.8 | Patch available | CNA |
- Print-O-Matic VendorUnknown Affected before 2.1.8 Fixed in 2.1.8 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:print-o-matic_project:print-o-matic:*:*:*:*:*:wordpress:*:* | before 2.1.8 | Vulnerable | Print-o-matic Project |
- cpe:2.3:a:print-o-matic_project:print-o-matic:*:*:*:*:*:wordpress:*:* Versions before 2.1.8 Vulnerable ·Print-o-matic Project
Remediation
- Fix · CNA Print-O-Matic (Unknown) Fixed in 2.1.8
Timeline
- 2026-10-02 Threatist record created from CVE-2022-4753
- 2026-10-03 Alias added: GHSA-rw59-8v68-3w3f
References
More Print-o-matic Project Print-o-matic vulnerabilities
- TI-2021-06992 Print-O-Matic < 2.0.3 - Admin+ Stored Cross-Site Scripting CVSS 3.1MEDIUM 4.8
Sources
- CVE-2022-4753 · CVE Program
- CVE-2022-4753 · NVD
- FIRST EPSS
- GHSA-rw59-8v68-3w3f · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences