Read the docs
TI-2022-04371 Aliases CVE-2022-4775GHSA-45j5-wmmf-563x

GeoDirectory < 2.2.22 - Contributor+ Stored XSS via Shortcode

Priority HIGH 66Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
Required
Attack complexity
Low
Impact type
—
Confidentiality · integrity · availability
Low · Low · None
Fix status
Fixed

Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA.

Summary

The GeoDirectory WordPress plugin before 2.2.22 does not validate and escape some of its shortcode attributes before outputting them back in the page, which could allow users with a role as low as contributor to perform Stored Cross-Site Scripting attacks which could be used against high privilege users such as admins.

Why it matters now

Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00476 41st percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA and NVD
Fix Fixed GeoDirectory (Unknown): 2.2.22

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
Poc
Automatable
Yes
Technical impact
Total

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
UnknownGeoDirectorybefore 2.2.222.2.22Patch availableCNA
  • GeoDirectory VendorUnknown Affected before 2.2.22 Fixed in 2.2.22 Patch available CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:ayecode:geodirectory:*:*:*:*:*:wordpress:*:*before 2.2.22VulnerableAyeCode Ltd
  • cpe:2.3:a:ayecode:geodirectory:*:*:*:*:*:wordpress:*:* Versions before 2.2.22 Vulnerable ·AyeCode Ltd

Remediation

  • Fix · CNA GeoDirectory (Unknown) Fixed in 2.2.22

Timeline

  1. 2026-10-02 Threatist record created from CVE-2022-4775
  2. 2026-10-03 Alias added: GHSA-45j5-wmmf-563x

References

  • TI-2024-28816 WordPress GeoDirectory plugin <= 2.3.61 - SQL Injection vulnerability CVSS 3.1HIGH 8.8
  • TI-2025-05608 GeoDirectory < 2.8.120 - Contributor+ Stored XSS CVSS 3.1MEDIUM 5.9
  • TI-2024-29570 WordPress GeoDirectory plugin <= 2.3.70 - Broken Access Control vulnerability CVSS 3.1HIGH 8.8
  • TI-2023-27750 WordPress GeoDirectory Plugin <= 2.3.28 is vulnerable to SQL Injection CVSS 3.1HIGH 7.6
  • TI-2024-37229 WordPress GeoDirectory plugin <= 2.3.84 - Cross Site Scripting (XSS) vulnerability CVSS 3.1MEDIUM 6.5
  • TI-2024-33870 WordPress GeoDirectory plugin <= 2.3.80 - Cross Site Scripting (XSS) vulnerability CVSS 3.1MEDIUM 6.5
See all 8 →

Sources