Read the docs
TI-2025-05608 Aliases CVE-2025-6200GHSA-987q-rh8g-5x3f

GeoDirectory < 2.8.120 - Contributor+ Stored XSS

Priority MEDIUM 60CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
High
User interaction
Required
Attack complexity
Low
Impact type
Cross-site scripting
Confidentiality · integrity · availability
Low · Low · Low
Fix status
Fixed

Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-79.

Summary

The GeoDirectory WordPress plugin before 2.8.120 does not validate and escape some of its shortcode attributes before outputting them back in a page/post where the shortcode is embed, which could allow users with the contributor role and above to perform Stored Cross-Site Scripting attacks.

Why it matters now

Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00245 15th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA and NVD
Fix Fixed GeoDirectory (Unknown): 2.8.120

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
Poc
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
UnknownGeoDirectorybefore 2.8.1202.8.120Patch availableCNA
  • GeoDirectory VendorUnknown Affected before 2.8.120 Fixed in 2.8.120 Patch available CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:ayecode:geodirectory:*:*:*:*:*:wordpress:*:*before 2.8.120VulnerableAyeCode Ltd
  • cpe:2.3:a:ayecode:geodirectory:*:*:*:*:*:wordpress:*:* Versions before 2.8.120 Vulnerable ·AyeCode Ltd

Remediation

  • Fix · CNA GeoDirectory (Unknown) Fixed in 2.8.120

Timeline

  1. 2026-10-02 Threatist record created from CVE-2025-6200
  2. 2026-10-03 Alias added: GHSA-987q-rh8g-5x3f

References

  • TI-2024-28816 WordPress GeoDirectory plugin <= 2.3.61 - SQL Injection vulnerability CVSS 3.1HIGH 8.8
  • TI-2022-04371 GeoDirectory < 2.2.22 - Contributor+ Stored XSS via Shortcode CVSS 3.1MEDIUM 5.4
  • TI-2024-29570 WordPress GeoDirectory plugin <= 2.3.70 - Broken Access Control vulnerability CVSS 3.1HIGH 8.8
  • TI-2023-27750 WordPress GeoDirectory Plugin <= 2.3.28 is vulnerable to SQL Injection CVSS 3.1HIGH 7.6
  • TI-2024-37229 WordPress GeoDirectory plugin <= 2.3.84 - Cross Site Scripting (XSS) vulnerability CVSS 3.1MEDIUM 6.5
  • TI-2024-33870 WordPress GeoDirectory plugin <= 2.3.80 - Cross Site Scripting (XSS) vulnerability CVSS 3.1MEDIUM 6.5
See all 8 →

Sources