Themify Shortcodes < 2.0.8 - Contributor+ Stored XSS via Shortcode
Priority MEDIUM 58CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-79.
Summary
Themify Shortcodes WordPress plugin before 2.0.8 does not validate and escape one of its shortcode attributes, which could allow users with a role as low as contributor to perform Stored Cross-Site Scripting attack.
Why it matters now
Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00471 40th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA and NVD
Fix Fixed Themify Shortcodes (Unknown): 2.0.8
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | Themify Shortcodes | before 2.0.8 | 2.0.8 | Patch available | CNA |
- Themify Shortcodes VendorUnknown Affected before 2.0.8 Fixed in 2.0.8 Patch available CNA
Remediation
- Fix · CNA Themify Shortcodes (Unknown) Fixed in 2.0.8
Timeline
- 2026-10-02 Threatist record created from CVE-2022-4787
- 2026-10-03 Alias added: GHSA-rv69-w27m-3wq2
References
Sources
- CVE-2022-4787 · CVE Program
- CVE-2022-4787 · NVD
- FIRST EPSS
- GHSA-rv69-w27m-3wq2 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences