Product Slider and Carousel with Category for WooCommerce < 2.8 - Contributor+ Stored XSS via Shortcode
Priority MEDIUM 58Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA.
Summary
The Product Slider and Carousel with Category for WooCommerce WordPress plugin before 2.8 does not validate and escape one of its shortcode attributes, which could allow users with a role as low as contributor to perform Stored Cross-Site Scripting attack.
Why it matters now
Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00471 40th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA and NVD
Fix Fixed Product Slider and Carousel with Category for WooCommerce (Unknown): 2.8
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | Product Slider and Carousel with Category for WooCommerce | before 2.8 | 2.8 | Patch available | CNA |
- Product Slider and Carousel with Category for WooCommerce VendorUnknown Affected before 2.8 Fixed in 2.8 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:essentialplugin:product_slider_and_carousel_with_category_with_woocommerce:*:*:*:*:*:wordpress:*:* | before 2.8 | Vulnerable | WP OnlineSupport, Essential Plugin |
- cpe:2.3:a:essentialplugin:product_slider_and_carousel_with_category_with_woocommerce:*:*:*:*:*:wordpress:*:* Versions before 2.8 Vulnerable ·WP OnlineSupport, Essential Plugin
Remediation
- Fix · CNA Product Slider and Carousel with Category for WooCommerce (Unknown) Fixed in 2.8
Timeline
- 2026-10-02 Threatist record created from CVE-2022-4791
- 2026-10-03 Alias added: GHSA-3mxw-j4x8-9xp2
References
Sources
- CVE-2022-4791 · CVE Program
- CVE-2022-4791 · NVD
- FIRST EPSS
- GHSA-3mxw-j4x8-9xp2 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences