News & Blog Designer Pack < 3.3 - Contributor+ Stored XSS via Shortcode
Priority MEDIUM 58Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA.
Summary
The News & Blog Designer Pack WordPress plugin before 3.3 does not validate and escape one of its shortcode attributes, which could allow users with a role as low as contributor to perform Stored Cross-Site Scripting attack.
Why it matters now
Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00438 38th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA and NVD
Fix Fixed News & Blog Designer Pack (Unknown): 3.3
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | News & Blog Designer Pack | before 3.3 | 3.3 | Patch available | CNA |
- News & Blog Designer Pack VendorUnknown Affected before 3.3 Fixed in 3.3 Patch available CNA
Remediation
- Fix · CNA News & Blog Designer Pack (Unknown) Fixed in 3.3
Timeline
- 2026-10-02 Threatist record created from CVE-2022-4792
- 2026-10-03 Alias added: GHSA-w599-8q9r-3vg8
References
More infornweb News & Blog Designer Pack vulnerabilities
- TI-2023-05351 News & Blog Designer Pack – WordPress Blog Plugin <= 3.4.1 - Unauthenticated Remote Code… CVSS 3.1CRITICAL 9.8
Sources
- CVE-2022-4792 · CVE Program
- CVE-2022-4792 · NVD
- FIRST EPSS
- GHSA-w599-8q9r-3vg8 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences