Read the docs
TI-2022-04420 Aliases CVE-2022-4824GHSA-f55v-qvgq-fhgw

WP Blog and Widget < 2.3.1 - Contributor+ Stored XSS via Shortcode

Priority MEDIUM 58CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
Required
Attack complexity
Low
Impact type
Cross-site scripting
Confidentiality · integrity · availability
Low · Low · None
Fix status
Fixed

Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-79.

Summary

The WP Blog and Widgets WordPress plugin before 2.3.1 does not validate and escape some of its shortcode attributes before outputting them back in the page, which could allow users with a role as low as contributor to perform Stored Cross-Site Scripting attacks which could be used against high privilege users such as admins.

Why it matters now

Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00649 51st percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA and NVD
Fix Fixed WP Blog and Widgets (Unknown): 2.3.1

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
Poc
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
UnknownWP Blog and Widgetsbefore 2.3.12.3.1Patch availableCNA
  • WP Blog and Widgets VendorUnknown Affected before 2.3.1 Fixed in 2.3.1 Patch available CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:essentialplugin:wp_blog_and_widget:*:*:*:*:*:wordpress:*:*before 2.3.1VulnerableWP OnlineSupport, Essential Plugin

Remediation

  • Fix · CNA WP Blog and Widgets (Unknown) Fixed in 2.3.1

Timeline

  1. 2026-10-02 Threatist record created from CVE-2022-4824
  2. 2026-10-03 Alias added: GHSA-f55v-qvgq-fhgw
  3. 2026-10-16 EPSS moved to the 50th–90th percentile

References

Sources