Read the docs
TI-2022-04425 Aliases CVE-2022-4829GHSA-4xcm-ff46-5j4r

Show-Hide / Collapse-Expand < 1.3.0 - Contributor+ Stored XSS via Shortcode

Priority MEDIUM 58Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
Required
Attack complexity
Low
Impact type
—
Confidentiality · integrity · availability
Low · Low · None
Fix status
Fixed

Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA.

Summary

The Show-Hide / Collapse-Expand WordPress plugin before 1.3.0 does not validate and escape some of its shortcode attributes before outputting them back in the page, which could allow users with a role as low as contributor to perform Stored Cross-Site Scripting attacks which could be used against high privilege users such as admins.

Why it matters now

Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.0049 42nd percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA and NVD
Fix Fixed Show-Hide / Collapse-Expand (Unknown): 1.3.0

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
Poc
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
UnknownShow-Hide / Collapse-Expandbefore 1.3.01.3.0Patch availableCNA
  • Show-Hide / Collapse-Expand VendorUnknown Affected before 1.3.0 Fixed in 1.3.0 Patch available CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:show-hide_\/_collapse-expand_project:show-hide_\/_collapse-expand:*:*:*:*:*:wordpress:*:*up to 1.2.5VulnerableShow-hide / Collapse-expand Project

Remediation

  • Fix · CNA Show-Hide / Collapse-Expand (Unknown) Fixed in 1.3.0

Timeline

  1. 2026-10-02 Threatist record created from CVE-2022-4829
  2. 2026-10-03 Alias added: GHSA-4xcm-ff46-5j4r

References

Sources