Read the docs
TI-2022-04428 Aliases CVE-2022-4832GHSA-ff5m-p28g-qvjf

Store Locator WordPress < 1.4.9 - Contributor+ Stored XSS via Shortcode

Priority MEDIUM 58Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
Required
Attack complexity
Low
Impact type
—
Confidentiality · integrity · availability
Low · Low · None
Fix status
Fixed

Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA.

Summary

The Store Locator WordPress plugin before 1.4.9 does not validate and escape some of its shortcode attributes before outputting them back in the page, which could allow users with a role as low as contributor to perform Stored Cross-Site Scripting attacks which could be used against high privilege users such as admins.

Why it matters now

Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00476 41st percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA and NVD
Fix Fixed Store Locator WordPress (Unknown): 1.4.9

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
Poc
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
UnknownStore Locator WordPressbefore 1.4.91.4.9Patch availableCNA
  • Store Locator WordPress VendorUnknown Affected before 1.4.9 Fixed in 1.4.9 Patch available CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:agilelogix:store_locator:*:*:*:*:*:wordpress:*:*before 1.4.9VulnerableAgile Logix
  • cpe:2.3:a:agilelogix:store_locator:*:*:*:*:*:wordpress:*:* Versions before 1.4.9 Vulnerable ·Agile Logix

Remediation

  • Fix · CNA Store Locator WordPress (Unknown) Fixed in 1.4.9

Timeline

  1. 2026-10-02 Threatist record created from CVE-2022-4832
  2. 2026-10-03 Alias added: GHSA-ff5m-p28g-qvjf

References

  • TI-2023-03840 Store Locator WordPress < 1.4.13 - Reflected XSS CVSS 3.1MEDIUM 6.1
  • TI-2023-12328 WordPress Store Locator WordPress Plugin <= 1.4.9 is vulnerable to Cross Site Scripting (XSS) CVSS 3.1MEDIUM 5.9
  • TI-2022-20018 WordPress Store Locator plugin <= 1.4.5 - Cross-Site Scripting (XSS) via Cross-Site Request Forgery (CSRF) vulnerability CVSS 3.1MEDIUM 6.1

Sources