Store Locator WordPress < 1.4.13 - Reflected XSS
Priority MEDIUM 60Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA.
Summary
The Store Locator WordPress plugin before 1.4.13 does not sanitise and escape an invalid nonce before outputting it back in an AJAX response, leading to a Reflected Cross-Site Scripting which could be used against high privilege users such as admin
Why it matters now
Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00688 52nd percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA
Fix Fixed Store Locator WordPress (Unknown): 1.4.13
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | Store Locator WordPress | before 1.4.13 | 1.4.13 | Patch available | CNA |
- Store Locator WordPress VendorUnknown Affected before 1.4.13 Fixed in 1.4.13 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:agilelogix:store_locator:*:*:*:*:*:wordpress:*:* | before 1.4.13 | Vulnerable | Agile Logix |
- cpe:2.3:a:agilelogix:store_locator:*:*:*:*:*:wordpress:*:* Versions before 1.4.13 Vulnerable ·Agile Logix
Remediation
- Fix · CNA Store Locator WordPress (Unknown) Fixed in 1.4.13
Timeline
- 2026-10-02 Threatist record created from CVE-2023-4151
- 2026-10-03 Alias added: GHSA-6c7x-v25p-8xx9
References
More Agile Logix Store Locator vulnerabilities
- TI-2022-04428 Store Locator WordPress < 1.4.9 - Contributor+ Stored XSS via Shortcode CVSS 3.1MEDIUM 5.4
- TI-2023-12328 WordPress Store Locator WordPress Plugin <= 1.4.9 is vulnerable to Cross Site Scripting (XSS) CVSS 3.1MEDIUM 5.9
- TI-2022-20018 WordPress Store Locator plugin <= 1.4.5 - Cross-Site Scripting (XSS) via Cross-Site Request Forgery (CSRF) vulnerability CVSS 3.1MEDIUM 6.1
Sources
- CVE-2023-4151 · CVE Program
- CVE-2023-4151 · NVD
- FIRST EPSS
- GHSA-6c7x-v25p-8xx9 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences