Cross-site Scripting (XSS) - Stored in usememos/memos
Priority HIGH 80CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
Cross-site Scripting (XSS) - Stored in GitHub repository usememos/memos prior to 0.9.1.
Why it matters now
Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.01058 64th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed usememos/memos (usememos): 0.9.1github.com/usememos/memos (Go): 0.9.1
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- Yes
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| usememos | usememos/memos | before 0.9.1 | 0.9.1 | Patch available | CNA |
| — | github.com/usememos/memos (Go) | before 0.9.1 | 0.9.1 | Patch available | GHSA-x9p9-v3x6-68mq |
- usememos/memos Vendorusememos Affected before 0.9.1 Fixed in 0.9.1 Patch available CNA
- github.com/usememos/memos (Go) Vendor— Affected before 0.9.1 Fixed in 0.9.1 Patch available GHSA-x9p9-v3x6-68mq
Remediation
- Fix · CNA usememos/memos (usememos) Fixed in 0.9.1
- Fix · GHSA-x9p9-v3x6-68mq github.com/usememos/memos (Go) Fixed in 0.9.1 Advisory →
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
usememos/memos 0.9.1
2 records Highest priority Priority HIGH 2 HIGH
Other records, highest priority first
- TI-2022-04458 Cross-site Scripting (XSS) - Stored in usememos/memosPriority HIGH 80
Timeline
- 2026-10-02 Threatist record created from CVE-2022-4866
- 2026-10-03 Alias added: GHSA-x9p9-v3x6-68mq
References
More usememos Memos vulnerabilities
- TI-2025-32234 The Memos application, up to version v0.24.3, allows for the embedding of markdown images… CVSS 3.1CRITICAL 9.8
- TI-2025-16796 elestio memos v0.23.0 is vulnerable to Server-Side Request Forgery (SSRF) due to… CVSS 3.1CRITICAL 9.8
- TI-2023-04328 Improper Access Control in usememos/memos CVSS 3.1CRITICAL 9.8
- TI-2022-04458 Cross-site Scripting (XSS) - Stored in usememos/memos CVSS 3.1CRITICAL 9.0
- TI-2022-04283 Authorization Bypass Through User-Controlled Key in usememos/memos CVSS 3.1CRITICAL 9.8
- TI-2024-27722 GHSL-2024-034: memos CORS Misconfiguration in server.go CVSS 3.1HIGH 8.1
Sources
- CVE-2022-4866 · CVE Program
- CVE-2022-4866 · NVD
- FIRST EPSS
- GHSA-x9p9-v3x6-68mq · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences