GHSL-2024-034: memos CORS Misconfiguration in server.go
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub.
Summary
memos is a privacy-first, lightweight note-taking service. A CORS misconfiguration exists in memos 0.20.1 and earlier where an arbitrary origin is reflected with Access-Control-Allow-Credentials set to true. This may allow an attacking website to make a cross-origin request, allowing the attacker to read private information or make privileged changes to the system as the vulnerable user account. This vulnerability is fixed in 0.21.0.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- Yes
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| usememos | memos | before 0.21.0 | 0.21.0 | Patch available | CNA |
| — | github.com/usememos/memos (Go) | before 0.21.0 | 0.21.0 | Patch available | GHSA-p4fx-qf2h-jpmj |
- memos Vendorusememos Affected before 0.21.0 Fixed in 0.21.0 Patch available CNA
- github.com/usememos/memos (Go) Vendor— Affected before 0.21.0 Fixed in 0.21.0 Patch available GHSA-p4fx-qf2h-jpmj
Remediation
- Fix · CNA memos (usememos) Fixed in 0.21.0
- Fix · GHSA-p4fx-qf2h-jpmj github.com/usememos/memos (Go) Fixed in 0.21.0 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2024-41659
- 2026-10-03 Alias added: GHSA-p4fx-qf2h-jpmj
- 2026-10-21 EPSS moved to the 50th–90th percentile
References
Advisory 2
More usememos Memos vulnerabilities
- TI-2025-32234 The Memos application, up to version v0.24.3, allows for the embedding of markdown images… CVSS 3.1CRITICAL 9.8
- TI-2025-16796 elestio memos v0.23.0 is vulnerable to Server-Side Request Forgery (SSRF) due to… CVSS 3.1CRITICAL 9.8
- TI-2023-04328 Improper Access Control in usememos/memos CVSS 3.1CRITICAL 9.8
- TI-2022-04459 Cross-site Scripting (XSS) - Stored in usememos/memos CVSS 3.1CRITICAL 9.0
- TI-2022-04458 Cross-site Scripting (XSS) - Stored in usememos/memos CVSS 3.1CRITICAL 9.0
- TI-2022-04283 Authorization Bypass Through User-Controlled Key in usememos/memos CVSS 3.1CRITICAL 9.8
Sources
- CVE-2024-41659 · CVE Program
- CVE-2024-41659 · NVD
- FIRST EPSS
- GHSA-p4fx-qf2h-jpmj · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences