Incorrect configuration handling allows TLS session re-use without re-validation in Envoy
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Spoofing
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and Red Hat. Impact type from CWE-295.
Summary
Envoy is an open source edge and service proxy, designed for cloud-native applications. Envoy's tls allows re-use when some cert validation settings have changed from their default configuration. The only workaround for this issue is to ensure that default tls settings are used. Users are advised to upgrade.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| envoyproxy | envoy | 1.7.0 to before 1.18.6; 1.19.0 to before 1.19.3; 1.20.0 to before 1.20.2; 1.21.0 to before 1.21.1 | 1.18.6, 1.19.3, 1.20.2, 1.21.1 | Patch available | CNA |
- envoy Vendorenvoyproxy Affected 1.7.0 to before 1.18.6; 1.19.0 to before 1.19.3; 1.20.0 to before 1.20.2; 1.21.0 to before 1.21.1 Fixed in 1.18.6, 1.19.3, 1.20.2, 1.21.1 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:envoyproxy:envoy:*:*:*:*:*:*:*:* | 1.7.0 to before 1.18.6; 1.19.0 to before 1.19.3; 1.20.0 to before 1.20.2; 1.21.0 to before 1.21.1 | Vulnerable | envoyproxy |
- cpe:2.3:a:envoyproxy:envoy:*:*:*:*:*:*:*:* Versions 1.7.0 to before 1.18.6; 1.19.0 to before 1.19.3; 1.20.0 to before 1.20.2; 1.21.0 to before 1.21.1 Vulnerable ·envoyproxy
Remediation
- Fix · CNA envoy (envoyproxy) Fixed in 1.18.6, 1.19.3, 1.20.2, 1.21.1
Red Hat 2 advisories
- RHSA-2022:1275 Released 2022-04-07 · Red Hat rating ImportantRed Hat OpenShift Service Mesh 2.1.2 security update
- OpenShift Service Mesh 2.1 servicemesh-2.1.2-4.el8, servicemesh-cni-2.1.2-4.el8, servicemesh-pilot-agent-2.1.2-4.el8 +3
- RHSA-2022:1276 Released 2022-04-07 · Red Hat rating ImportantRed Hat OpenShift Service Mesh 2.0.9 security update
- OpenShift Service Mesh 2.0 kiali-v1.24.7.redhat1-1.el8, servicemesh-2.0.9-3.el8, servicemesh-istioctl-2.0.9-3.el8 +6
Vendor assessments
Red Hat
Red Hat rating: Important. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| OpenShift Service Mesh 2.0 | Fixed | RHSA-2022:1276 |
| OpenShift Service Mesh 2.1 | Fixed | RHSA-2022:1275 |
Not affected: 2 products
- OpenShift Service Mesh 2.0
- OpenShift Service Mesh 2.1
Timeline
- 2026-10-02 Threatist record created from CVE-2022-21654
References
More envoyproxy Envoy vulnerabilities
- TI-2026-79288 Out-of-bounds write in Google Brotli decoder KEVCVSS 4.0CRITICAL 9.2
- TI-2023-23979 The HTTP/2 protocol allows a denial of service (server resource consumption) because… KEVCVSS 3.1HIGH 7.5
- TI-2024-20001 HTTP/2: CPU exhaustion due to CONTINUATION frame flood CVSS 3.1HIGH 7.5
- TI-2024-18524 HTTP/2: memory exhaustion due to CONTINUATION frame flood CVSS 3.1HIGH 7.5
- TI-2023-12215 Envoy client may fake the header `x-envoy-original-path` CVSS 3.1CRITICAL 9.1
- TI-2023-18002 Envoy vulnerable to OAuth2 credentials exploit with permanent validity CVSS 3.1CRITICAL 9.8
Sources
- CVE-2022-21654 · CVE Program
- CVE-2022-21654 · NVD
- FIRST EPSS
- CVE-2022-21654 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences