Arbitrary code execution in joblib
Priority HIGH 82CWE-94Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-94.
Summary
The package joblib from 0 and before 1.2.0 are vulnerable to Arbitrary Code Execution via the pre_dispatch flag in Parallel() class due to the eval() statement.
Why it matters now
Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.02627 85th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed joblib: 1.2.0joblib (PyPI): 1.2.0
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- Yes
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | joblib | all versions; before 1.2.0 | 1.2.0 | Patch available | CNA |
| — | joblib (PyPI) | before 1.2.0 | 1.2.0 | Patch available | GHSA-6hrg-qmvc-2xh8 |
- joblib Vendor— Affected all versions; before 1.2.0 Fixed in 1.2.0 Patch available CNA
- joblib (PyPI) Vendor— Affected before 1.2.0 Fixed in 1.2.0 Patch available GHSA-6hrg-qmvc-2xh8
CPE configurations NVD · 4
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:joblib_project:joblib:*:*:*:*:*:python:*:* | before 1.1.1 | Vulnerable | Joblib Project |
| cpe:2.3:o:fedoraproject:fedora:36:*:*:*:*:*:*:* | 36 | Vulnerable | Fedoraproject |
| cpe:2.3:o:fedoraproject:fedora:37:*:*:*:*:*:*:* | 37 | Vulnerable | Fedoraproject |
| cpe:2.3:o:debian:debian_linux:10.0:*:*:*:*:*:*:* | 10.0 | Vulnerable | Debian |
- cpe:2.3:a:joblib_project:joblib:*:*:*:*:*:python:*:* Versions before 1.1.1 Vulnerable ·Joblib Project
- cpe:2.3:o:fedoraproject:fedora:36:*:*:*:*:*:*:* Versions 36 Vulnerable ·Fedoraproject
- cpe:2.3:o:fedoraproject:fedora:37:*:*:*:*:*:*:* Versions 37 Vulnerable ·Fedoraproject
- cpe:2.3:o:debian:debian_linux:10.0:*:*:*:*:*:*:* Versions 10.0 Vulnerable ·Debian
Remediation
- Fix · CNA joblib Fixed in 1.2.0
- Fix · GHSA-6hrg-qmvc-2xh8 joblib (PyPI) Fixed in 1.2.0 Advisory →
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2022-21797
- 2026-10-03 Alias added: GHSA-6hrg-qmvc-2xh8
References
Patch 2
Advisory 6
Other 9
- https://github.com/joblib/joblib/pull/1327
- https://github.com/joblib/joblib/pull/1352
- https://github.com/joblib/joblib/commit/6638b9e9711ad1ebbf6dd95aa7cee0dca9897b42
- https://lists.fedoraproject.org/archives/list/[email protected]/message/MJ5XTJS6OKJRRVXWFN5J67K3BYPEOBDF
- https://lists.fedoraproject.org/archives/list/[email protected]/message/BVOMMW37OXZWU2EV5ONAAS462IQEHZOF
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/MJ5XTJS6OKJRRVXWFN5J67K3BYPEOBDF
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/BVOMMW37OXZWU2EV5ONAAS462IQEHZOF
- https://github.com/pypa/advisory-database/tree/main/vulns/joblib/PYSEC-2022-288.yaml
- https://github.com/joblib/joblib
Sources
- CVE-2022-21797 · CVE Program
- CVE-2022-21797 · NVD
- FIRST EPSS
- GHSA-6hrg-qmvc-2xh8 · GitHub Advisory Database · CC BY 4.0
- CVE-2022-21797 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences