Improper authorization vulnerability in Galaxy Store prior to 4.5.36.5 allows remote app installation of the allowlist.
Priority LOW 35CWE-285Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-285.
Summary
Improper authorization vulnerability in Galaxy Store prior to 4.5.36.5 allows remote app installation of the allowlist.
Why it matters now
EPSS 0.0095 61st percentileScored 2026-11-07
Fix Fixed Galaxy Store (Samsung Mobile): 4.5.36.5
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
Remediation
- Fix · CNA Galaxy Store (Samsung Mobile) Fixed in 4.5.36.5
Timeline
- 2026-10-02 Threatist record created from CVE-2022-22288
- 2026-10-03 Alias added: GHSA-mf8r-2pp6-7vqp
References
More Samsung Galaxy Store vulnerabilities
- TI-2023-07917 Improper input validation in Samsung Galaxy Store CVSS 3.1CRITICAL 9.6
- TI-2023-07916 Improper input validation in Samsung Galaxy Store CVSS 3.1HIGH 8.8
- TI-2023-22730 Improper URL validation from MCSLaunch deeplink in Galaxy Store prior to version 4.5.64.4… CVSS 3.1CRITICAL 9.8
- TI-2023-07835 Improper input validation in Samsung Galaxy Store CVSS 3.1MEDIUM 6.2
- TI-2023-07834 Improper authorization in Samsung Galaxy Store CVSS 3.1HIGH 7.8
- TI-2023-07915 Improper input validation in Samsung Galaxy Store CVSS 3.1HIGH 8.8
Sources
- CVE-2022-22288 · CVE Program
- CVE-2022-22288 · NVD
- FIRST EPSS
- GHSA-mf8r-2pp6-7vqp · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences