Insufficiently protected credentials in Dell PowerStore
Key facts
- Attack vector
- Local
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-256.
Summary
PowerStore contains Plain-Text Password Storage Vulnerability in PowerStore X & T environments running versions 2.0.0.x and 2.0.1.x A locally authenticated attacker could potentially exploit this vulnerability, leading to the disclosure of certain user credentials. The attacker may be able to use the exposed credentials to access the vulnerable application with privileges of the compromised account.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Dell | PowerStore | before PowerStore SW v2.1.0.0-1553419 | PowerStore SW v2.1.0.0-1553419 | Patch available | CNA |
- PowerStore VendorDell Affected before PowerStore SW v2.1.0.0-1553419 Fixed in PowerStore SW v2.1.0.0-1553419 Patch available CNA
CPE configurations NVD · 4
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:o:dell:powerstoreos:*:*:*:*:*:*:*:* | 2.0.0.0 to before 2.1.0.0 | Vulnerable | Dell |
| cpe:2.3:h:dell:powerstore_t:-:*:*:*:*:*:*:* | not specified by NVD | Running on | Dell |
| cpe:2.3:o:dell:powerstoreos:*:*:*:*:*:*:*:* | 2.0.0.0 to before 2.1.1.0 | Vulnerable | Dell |
| cpe:2.3:h:dell:powerstore_x:-:*:*:*:*:*:*:* | not specified by NVD | Running on | Dell |
- cpe:2.3:o:dell:powerstoreos:*:*:*:*:*:*:*:* Versions 2.0.0.0 to before 2.1.0.0 Vulnerable ·Dell
- cpe:2.3:h:dell:powerstore_t:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·Dell
- cpe:2.3:o:dell:powerstoreos:*:*:*:*:*:*:*:* Versions 2.0.0.0 to before 2.1.1.0 Vulnerable ·Dell
- cpe:2.3:h:dell:powerstore_x:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·Dell
Remediation
- Fix · CNA PowerStore (Dell) Fixed in PowerStore SW v2.1.0.0-1553419
Timeline
- 2026-10-02 Threatist record created from CVE-2022-22557
- 2026-10-03 Alias added: GHSA-xfxv-hqvj-fpfc
References
More Dell Powerstoreos vulnerabilities
- TI-2026-42160 Missing authentication in Dell PowerStore 500T CVSS 3.1CRITICAL 9.8
- TI-2022-10113 Information disclosure in Dell PowerStore CVSS 3.1CRITICAL 9.8
- TI-2026-55184 Missing authentication in Dell PowerStore 500T CVSS 3.1CRITICAL 10.0
- TI-2022-10114 Authentication bypass in Dell PowerStore CVSS 3.1CRITICAL 9.8
- TI-2026-55183 Protection mechanism failure in Dell PowerStore 500T CVSS 3.1HIGH 8.8
- TI-2026-55181 Protection mechanism failure in Dell PowerStore 500T CVSS 3.1HIGH 8.8
Sources
- CVE-2022-22557 · CVE Program
- CVE-2022-22557 · NVD
- FIRST EPSS
- GHSA-xfxv-hqvj-fpfc · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences