Unchecked return value from xmlTextReaderExpand in Nokogiri
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Denial of service
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- Partial Red Hat: 4 without a fix
Attack profile from CVSS 3.1 · CNA. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-476.
Summary
Nokogiri is an open source XML and HTML library for the Ruby programming language. Nokogiri `1.13.8` and `1.13.9` fail to check the return value from `xmlTextReaderExpand` in the method `Nokogiri::XML::Reader#attribute_hash`. This can lead to a null pointer exception when invalid markup is being parsed. For applications using `XML::Reader` to parse untrusted inputs, this may potentially be a vector for a denial of service attack. Users are advised to upgrade to Nokogiri `>= 1.13.10`. Users may be able to search their code for calls to either `XML::Reader#attributes` or `XML::Reader#attribute_hash` to determine if they are affected.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| sparklemotion | nokogiri | 1.13.8 to before 1.13.10 | 1.13.10 | Patch available | CNA |
| — | nokogiri (RubyGems) | 1.13.8 to before 1.13.10 | 1.13.10 | Patch available | GHSA-qv4q-mr5r-qprj |
- nokogiri Vendorsparklemotion Affected 1.13.8 to before 1.13.10 Fixed in 1.13.10 Patch available CNA
- nokogiri (RubyGems) Vendor— Affected 1.13.8 to before 1.13.10 Fixed in 1.13.10 Patch available GHSA-qv4q-mr5r-qprj
CPE configurations NVD · 2
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:nokogiri:nokogiri:1.13.8:*:*:*:*:ruby:*:* | 1.13.8 | Vulnerable | sparklemotion |
| cpe:2.3:a:nokogiri:nokogiri:1.13.9:*:*:*:*:ruby:*:* | 1.13.9 | Vulnerable | sparklemotion |
- cpe:2.3:a:nokogiri:nokogiri:1.13.8:*:*:*:*:ruby:*:* Versions 1.13.8 Vulnerable ·sparklemotion
- cpe:2.3:a:nokogiri:nokogiri:1.13.9:*:*:*:*:ruby:*:* Versions 1.13.9 Vulnerable ·sparklemotion
Remediation
- Fix · CNA nokogiri (sparklemotion) Fixed in 1.13.10
- Fix · GHSA-qv4q-mr5r-qprj nokogiri (RubyGems) Fixed in 1.13.10 Advisory →
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat Ceph Storage 6 | Affected | No fix planned: Will not fix |
| Red Hat Ceph Storage 7 | Affected | No fix yet |
| Red Hat Ceph Storage 8 | Affected | No fix yet |
| Red Hat Ceph Storage 9 | Affected | No fix yet |
Not affected: 3 products
- CloudForms Management Engine 5
- Red Hat 3scale API Management Platform 2
- Red Hat Satellite 6
Timeline
- 2026-10-02 Threatist record created from CVE-2022-23476
- 2026-10-03 Alias added: GHSA-qv4q-mr5r-qprj
References
Patch 2
Advisory 2
More sparklemotion Nokogiri vulnerabilities
- TI-2022-11724 Improper Handling of Unexpected Data Type in Nokogiri CVSS 3.1HIGH 8.2
- TI-2018-15259 zlib before 1.2.12 allows memory corruption when deflating (i.e., when compressing) if… CVSS 3.1HIGH 7.5
- TI-2019-03885 OS command injection in Nokogiri CVSS 3.1CRITICAL 9.8
- TI-2026-55247 Nokogiri before 1.19.3 ReDoS via CSS selector tokenizer CVSS 4.0HIGH 8.7
- TI-2022-08648 Inefficient Regular Expression Complexity in Nokogiri CVSS 3.1HIGH 7.5
- TI-2026-55248 Nokogiri before 1.19.3 Memory Leak via XSLT Transform CVSS 4.0MEDIUM 6.9
Sources
- CVE-2022-23476 · CVE Program
- CVE-2022-23476 · NVD
- FIRST EPSS
- GHSA-qv4q-mr5r-qprj · GitHub Advisory Database · CC BY 4.0
- CVE-2022-23476 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences