Nokogiri before 1.19.3 ReDoS via CSS selector tokenizer
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- Denial of service
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA and GitHub. Impact type from CWE-1333.
Summary
Nokogiri versions before 1.19.3 contain regular expression denial of service vulnerabilities in the CSS selector tokenizer affecting string-literal and identifier tokenization. Attackers can inject adversarial CSS selectors into methods like Node#css, Node#at_css, and Searchable#search to cause exponential regex backtracking and denial of service.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| sparklemotion | nokogiri | before 1.19.3 | 1.19.3 | Patch available | CNA |
| — | nokogiri (RubyGems) | before 1.19.3 | 1.19.3 | Patch available | GHSA-c4rq-3m3g-8wgx |
- nokogiri Vendorsparklemotion Affected before 1.19.3 Fixed in 1.19.3 Patch available CNA
- nokogiri (RubyGems) Vendor— Affected before 1.19.3 Fixed in 1.19.3 Patch available GHSA-c4rq-3m3g-8wgx
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:nokogiri:nokogiri:*:*:*:*:*:ruby:*:* | before 1.19.3 | Vulnerable | sparklemotion |
- cpe:2.3:a:nokogiri:nokogiri:*:*:*:*:*:ruby:*:* Versions before 1.19.3 Vulnerable ·sparklemotion
Remediation
- Fix · CNA nokogiri (sparklemotion) Fixed in 1.19.3
- Fix · GHSA-c4rq-3m3g-8wgx nokogiri (RubyGems) Fixed in 1.19.3 Advisory →
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
sparklemotion nokogiri 1.19.3
2 records Highest priority Priority MEDIUM 1 MEDIUM, 1 LOW
Other records, highest priority first
- TI-2026-55248 Nokogiri before 1.19.3 Memory Leak via XSLT TransformPriority LOW 37
Vendor assessments
Red Hat
Red Hat rating: Important. Red Hat's page for this CVE →
Not affected: 2 products
- Red Hat 3scale API Management Platform 2
- Red Hat Satellite 6
Timeline
- 2026-10-02 Threatist record created from CVE-2026-79770
- 2026-10-03 Alias added: GHSA-c4rq-3m3g-8wgx
References
More sparklemotion Nokogiri vulnerabilities
- TI-2022-11724 Improper Handling of Unexpected Data Type in Nokogiri CVSS 3.1HIGH 8.2
- TI-2018-15259 zlib before 1.2.12 allows memory corruption when deflating (i.e., when compressing) if… CVSS 3.1HIGH 7.5
- TI-2019-03885 OS command injection in Nokogiri CVSS 3.1CRITICAL 9.8
- TI-2022-07536 Unchecked return value from xmlTextReaderExpand in Nokogiri CVSS 3.1HIGH 7.5
- TI-2022-08648 Inefficient Regular Expression Complexity in Nokogiri CVSS 3.1HIGH 7.5
- TI-2026-55248 Nokogiri before 1.19.3 Memory Leak via XSLT Transform CVSS 4.0MEDIUM 6.9
Sources
- CVE-2026-79770 · CVE Program
- CVE-2026-79770 · NVD
- FIRST EPSS
- GHSA-c4rq-3m3g-8wgx · GitHub Advisory Database · CC BY 4.0
- CVE-2026-79770 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences