libp2p-rust denial of service vulnerability from lack of resource management
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Denial of service
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-400.
Summary
libp2p-rust is the official rust language Implementation of the libp2p networking stack. In versions prior to 0.45.1 an attacker node can cause a victim node to allocate a large number of small memory chunks, which can ultimately lead to the victim’s process running out of memory and thus getting killed by its operating system. When executed continuously, this can lead to a denial of service attack, especially relevant on a larger scale when run against more than one node of a libp2p based network. Users are advised to upgrade to `libp2p` `v0.45.1` or above. Users unable to upgrade should reference the DoS Mitigation page for more information on how to incorporate mitigation strategies, monitor their application, and respond to attacks: https://docs.libp2p.io/reference/dos-mitigation/.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| libp2p | rust-libp2p | before 0.45.1 | 0.45.1 | Patch available | CNA |
| — | libp2p (crates.io) | before 0.45.1 | 0.45.1 | Patch available | GHSA-jvgw-gccv-q5p8 |
- rust-libp2p Vendorlibp2p Affected before 0.45.1 Fixed in 0.45.1 Patch available CNA
- libp2p (crates.io) Vendor— Affected before 0.45.1 Fixed in 0.45.1 Patch available GHSA-jvgw-gccv-q5p8
Remediation
- Fix · CNA rust-libp2p (libp2p) Fixed in 0.45.1
- Fix · GHSA-jvgw-gccv-q5p8 libp2p (crates.io) Fixed in 0.45.1 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2022-23486
- 2026-10-03 Alias added: GHSA-jvgw-gccv-q5p8
References
Advisory 2
More libp2p vulnerabilities
- TI-2026-60386 libp2p-rendezvous through 0.17.1 Denial of Service via Unbounded Registration TTL in Discovery Responses CVSS 4.0HIGH 8.7
- TI-2026-58865 libp2p: PeerStore accepts attacker-signed PeerRecords for a victim peer ID and stores certified attacker addresses CVSS 3.1HIGH 8.2
- TI-2026-44102 libp2p-quic: Remote panic via certificate expiry race during QUIC handshake CVSS 4.0HIGH 8.2
- TI-2026-27587 libp2p-rust has unbounded rendezvous DISCOVER cookies enable remote memory exhaustion CVSS 3.1HIGH 8.2
- TI-2026-58864 libp2p: Gossipsub StrictSign accepts attacker-signed messages as a victim RSA peer ID CVSS 3.1HIGH 7.5
- TI-2026-53982 libp2p: Circuit relay v2 server reservation refresh leaks abort listeners and allows remote resource exhaustion CVSS 3.1HIGH 7.5
Sources
- CVE-2022-23486 · CVE Program
- CVE-2022-23486 · NVD
- FIRST EPSS
- GHSA-jvgw-gccv-q5p8 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences