Read the docs
TI-2022-07613 Aliases CVE-2022-23560GHSA-4hvf-hxvg-f67v

Read and Write outside of bounds in TFLite

Priority HIGH 73CWE-125Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
None
Attack complexity
Low
Impact type
Code execution
Confidentiality · integrity · availability
High · High · High
Fix status
Fixed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-787 and the CVSS impact.

Summary

Tensorflow is an Open Source Machine Learning Framework. An attacker can craft a TFLite model that would allow limited reads and writes outside of arrays in TFLite. This exploits missing validation in the conversion from sparse tensors to dense tensors. The fix is included in TensorFlow 2.8.0. We will also cherrypick this commit on TensorFlow 2.7.1, TensorFlow 2.6.3, and TensorFlow 2.5.3, as these are also affected and still in supported range. Users are advised to upgrade as soon as possible.

Why it matters now

Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00844 58th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed tensorflow (tensorflow): 2.7.1, 2.6.3, 2.5.3tensorflow (PyPI): 2.5.3, 2.6.3, 2.7.1+2 more products

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
Poc
Automatable
No
Technical impact
Total

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
Googletensorflow2.7.0 to before 2.7.1; 2.6.0 to before 2.6.3; before 2.5.32.7.1, 2.6.3, 2.5.3Patch availableCNA
—tensorflow (PyPI)before 2.5.32.5.3Patch availableGHSA-4hvf-hxvg-f67v
—tensorflow (PyPI)2.6.0 to before 2.6.32.6.3Patch availableGHSA-4hvf-hxvg-f67v
—tensorflow (PyPI)2.7.0 to before 2.7.12.7.1Patch availableGHSA-4hvf-hxvg-f67v
—tensorflow-cpu (PyPI)before 2.5.32.5.3Patch availableGHSA-4hvf-hxvg-f67v
—tensorflow-cpu (PyPI)2.6.0 to before 2.6.32.6.3Patch availableGHSA-4hvf-hxvg-f67v
—tensorflow-cpu (PyPI)2.7.0 to before 2.7.12.7.1Patch availableGHSA-4hvf-hxvg-f67v
—tensorflow-gpu (PyPI)before 2.5.32.5.3Patch availableGHSA-4hvf-hxvg-f67v
—tensorflow-gpu (PyPI)2.6.0 to before 2.6.32.6.3Patch availableGHSA-4hvf-hxvg-f67v
—tensorflow-gpu (PyPI)2.7.0 to before 2.7.12.7.1Patch availableGHSA-4hvf-hxvg-f67v
  • tensorflow VendorGoogle Affected 2.7.0 to before 2.7.1; 2.6.0 to before 2.6.3; before 2.5.3 Fixed in 2.7.1, 2.6.3, 2.5.3 Patch available CNA
  • tensorflow (PyPI) Vendor— Affected before 2.5.3 Fixed in 2.5.3 Patch available GHSA-4hvf-hxvg-f67v
  • tensorflow (PyPI) Vendor— Affected 2.6.0 to before 2.6.3 Fixed in 2.6.3 Patch available GHSA-4hvf-hxvg-f67v
  • tensorflow (PyPI) Vendor— Affected 2.7.0 to before 2.7.1 Fixed in 2.7.1 Patch available GHSA-4hvf-hxvg-f67v
  • tensorflow-cpu (PyPI) Vendor— Affected before 2.5.3 Fixed in 2.5.3 Patch available GHSA-4hvf-hxvg-f67v
  • tensorflow-cpu (PyPI) Vendor— Affected 2.6.0 to before 2.6.3 Fixed in 2.6.3 Patch available GHSA-4hvf-hxvg-f67v
  • tensorflow-cpu (PyPI) Vendor— Affected 2.7.0 to before 2.7.1 Fixed in 2.7.1 Patch available GHSA-4hvf-hxvg-f67v
  • tensorflow-gpu (PyPI) Vendor— Affected before 2.5.3 Fixed in 2.5.3 Patch available GHSA-4hvf-hxvg-f67v
  • tensorflow-gpu (PyPI) Vendor— Affected 2.6.0 to before 2.6.3 Fixed in 2.6.3 Patch available GHSA-4hvf-hxvg-f67v
  • tensorflow-gpu (PyPI) Vendor— Affected 2.7.0 to before 2.7.1 Fixed in 2.7.1 Patch available GHSA-4hvf-hxvg-f67v

CPE configurations NVD · 2

CPEVersionsRoleVendor
cpe:2.3:a:google:tensorflow:*:*:*:*:*:*:*:*up to 2.5.2; 2.6.0 – 2.6.2VulnerableGoogle
cpe:2.3:a:google:tensorflow:2.7.0:*:*:*:*:*:*:*2.7.0VulnerableGoogle
  • cpe:2.3:a:google:tensorflow:*:*:*:*:*:*:*:* Versions up to 2.5.2; 2.6.0 – 2.6.2 Vulnerable ·Google
  • cpe:2.3:a:google:tensorflow:2.7.0:*:*:*:*:*:*:* Versions 2.7.0 Vulnerable ·Google

Remediation

  • Fix · CNA tensorflow (tensorflow) Fixed in 2.7.1, 2.6.3, 2.5.3
  • Fix · GHSA-4hvf-hxvg-f67v tensorflow (PyPI) Fixed in 2.5.3 Advisory →
  • Fix · GHSA-4hvf-hxvg-f67v tensorflow (PyPI) Fixed in 2.6.3 Advisory →
  • Fix · GHSA-4hvf-hxvg-f67v tensorflow (PyPI) Fixed in 2.7.1 Advisory →
  • Fix · GHSA-4hvf-hxvg-f67v tensorflow-cpu (PyPI) Fixed in 2.5.3 Advisory →
  • Fix · GHSA-4hvf-hxvg-f67v tensorflow-cpu (PyPI) Fixed in 2.6.3 Advisory →
  • Fix · GHSA-4hvf-hxvg-f67v tensorflow-cpu (PyPI) Fixed in 2.7.1 Advisory →
  • Fix · GHSA-4hvf-hxvg-f67v tensorflow-gpu (PyPI) Fixed in 2.5.3 Advisory →
  • Fix · GHSA-4hvf-hxvg-f67v tensorflow-gpu (PyPI) Fixed in 2.6.3 Advisory →
  • Fix · GHSA-4hvf-hxvg-f67v tensorflow-gpu (PyPI) Fixed in 2.7.1 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2022-23560
  2. 2026-10-03 Alias added: GHSA-4hvf-hxvg-f67v

References

  • TI-2022-20241 FractionalMaxPool and FractionalAVGPool heap out-of-bounds acess in Tensorflow CVSS 3.1CRITICAL 9.8
  • TI-2022-07640 Integer overflow in Tensorflow CVSS 3.1CRITICAL 9.8
  • TI-2022-07627 Out of bounds read and write in Tensorflow CVSS 3.1HIGH 8.8
  • TI-2022-07619 Out of bounds write in Tensorflow CVSS 3.1HIGH 8.8
  • TI-2022-07612 Integer overflow in TFLite CVSS 3.1HIGH 8.8
  • TI-2025-35039 An issue was discovered TensorFlow v2.18.0. CVSS 3.1HIGH 7.5
See all 430 →

Sources