Read the docs
TI-2022-20241 Aliases CVE-2022-41900GHSA-xvwp-h6jv-7472

FractionalMaxPool and FractionalAVGPool heap out-of-bounds acess in Tensorflow

Priority HIGH 76CWE-125Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
Code execution
Confidentiality · integrity · availability
High · High · High
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-787 and the CVSS impact.

Summary

TensorFlow is an open source platform for machine learning. The security vulnerability results in FractionalMax(AVG)Pool with illegal pooling_ratio. Attackers using Tensorflow can exploit the vulnerability. They can access heap memory which is not in the control of user, leading to a crash or remote code execution. We have patched the issue in GitHub commit 216525144ee7c910296f5b05d214ca1327c9ce48. The fix will be included in TensorFlow 2.11.0. We will also cherry pick this commit on TensorFlow 2.10.1.

Why it matters now

Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00658 51st percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed tensorflow (tensorflow): 2.10.1, 2.9.3, 2.8.4tensorflow (PyPI): 2.8.4, 2.9.3, 2.10.1+2 more products

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
Poc
Automatable
No
Technical impact
Total

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
Googletensorflow2.10.0 to before 2.10.1; 2.9.0 to before 2.9.3; before 2.8.42.10.1, 2.9.3, 2.8.4Patch availableCNA
—tensorflow (PyPI)before 2.8.42.8.4Patch availableGHSA-xvwp-h6jv-7472
—tensorflow (PyPI)2.9.0 to before 2.9.32.9.3Patch availableGHSA-xvwp-h6jv-7472
—tensorflow (PyPI)2.10.0 to before 2.10.12.10.1Patch availableGHSA-xvwp-h6jv-7472
—tensorflow-cpu (PyPI)before 2.8.42.8.4Patch availableGHSA-xvwp-h6jv-7472
—tensorflow-gpu (PyPI)before 2.8.42.8.4Patch availableGHSA-xvwp-h6jv-7472
—tensorflow-cpu (PyPI)2.9.0 to before 2.9.32.9.3Patch availableGHSA-xvwp-h6jv-7472
—tensorflow-gpu (PyPI)2.9.0 to before 2.9.32.9.3Patch availableGHSA-xvwp-h6jv-7472
—tensorflow-cpu (PyPI)2.10.0 to before 2.10.12.10.1Patch availableGHSA-xvwp-h6jv-7472
—tensorflow-gpu (PyPI)2.10.0 to before 2.10.12.10.1Patch availableGHSA-xvwp-h6jv-7472
  • tensorflow VendorGoogle Affected 2.10.0 to before 2.10.1; 2.9.0 to before 2.9.3; before 2.8.4 Fixed in 2.10.1, 2.9.3, 2.8.4 Patch available CNA
  • tensorflow (PyPI) Vendor— Affected before 2.8.4 Fixed in 2.8.4 Patch available GHSA-xvwp-h6jv-7472
  • tensorflow (PyPI) Vendor— Affected 2.9.0 to before 2.9.3 Fixed in 2.9.3 Patch available GHSA-xvwp-h6jv-7472
  • tensorflow (PyPI) Vendor— Affected 2.10.0 to before 2.10.1 Fixed in 2.10.1 Patch available GHSA-xvwp-h6jv-7472
  • tensorflow-cpu (PyPI) Vendor— Affected before 2.8.4 Fixed in 2.8.4 Patch available GHSA-xvwp-h6jv-7472
  • tensorflow-gpu (PyPI) Vendor— Affected before 2.8.4 Fixed in 2.8.4 Patch available GHSA-xvwp-h6jv-7472
  • tensorflow-cpu (PyPI) Vendor— Affected 2.9.0 to before 2.9.3 Fixed in 2.9.3 Patch available GHSA-xvwp-h6jv-7472
  • tensorflow-gpu (PyPI) Vendor— Affected 2.9.0 to before 2.9.3 Fixed in 2.9.3 Patch available GHSA-xvwp-h6jv-7472
  • tensorflow-cpu (PyPI) Vendor— Affected 2.10.0 to before 2.10.1 Fixed in 2.10.1 Patch available GHSA-xvwp-h6jv-7472
  • tensorflow-gpu (PyPI) Vendor— Affected 2.10.0 to before 2.10.1 Fixed in 2.10.1 Patch available GHSA-xvwp-h6jv-7472

CPE configurations NVD · 2

CPEVersionsRoleVendor
cpe:2.3:a:google:tensorflow:*:*:*:*:*:*:*:*before 2.8.4; 2.9.0 to before 2.9.3VulnerableGoogle
cpe:2.3:a:google:tensorflow:2.10.0:*:*:*:*:*:*:*2.10.0VulnerableGoogle
  • cpe:2.3:a:google:tensorflow:*:*:*:*:*:*:*:* Versions before 2.8.4; 2.9.0 to before 2.9.3 Vulnerable ·Google
  • cpe:2.3:a:google:tensorflow:2.10.0:*:*:*:*:*:*:* Versions 2.10.0 Vulnerable ·Google

Remediation

  • Fix · CNA tensorflow (tensorflow) Fixed in 2.10.1, 2.9.3, 2.8.4
  • Fix · GHSA-xvwp-h6jv-7472 tensorflow (PyPI) Fixed in 2.8.4 Advisory →
  • Fix · GHSA-xvwp-h6jv-7472 tensorflow (PyPI) Fixed in 2.9.3 Advisory →
  • Fix · GHSA-xvwp-h6jv-7472 tensorflow (PyPI) Fixed in 2.10.1 Advisory →
  • Fix · GHSA-xvwp-h6jv-7472 tensorflow-cpu (PyPI) Fixed in 2.8.4 Advisory →
  • Fix · GHSA-xvwp-h6jv-7472 tensorflow-gpu (PyPI) Fixed in 2.8.4 Advisory →
  • Fix · GHSA-xvwp-h6jv-7472 tensorflow-cpu (PyPI) Fixed in 2.9.3 Advisory →
  • Fix · GHSA-xvwp-h6jv-7472 tensorflow-gpu (PyPI) Fixed in 2.9.3 Advisory →
  • Fix · GHSA-xvwp-h6jv-7472 tensorflow-cpu (PyPI) Fixed in 2.10.1 Advisory →
  • Fix · GHSA-xvwp-h6jv-7472 tensorflow-gpu (PyPI) Fixed in 2.10.1 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2022-41900
  2. 2026-10-03 Alias added: GHSA-xvwp-h6jv-7472
  3. 2026-10-24 EPSS moved to the 50th–90th percentile

References

  • TI-2022-07640 Integer overflow in Tensorflow CVSS 3.1CRITICAL 9.8
  • TI-2022-07627 Out of bounds read and write in Tensorflow CVSS 3.1HIGH 8.8
  • TI-2022-07619 Out of bounds write in Tensorflow CVSS 3.1HIGH 8.8
  • TI-2022-07613 Read and Write outside of bounds in TFLite CVSS 3.1HIGH 8.8
  • TI-2022-07612 Integer overflow in TFLite CVSS 3.1HIGH 8.8
  • TI-2025-35039 An issue was discovered TensorFlow v2.18.0. CVSS 3.1HIGH 7.5
See all 430 →

Sources