Cross-site Scripting in svg-sanitizer
Priority LOW 29CWE-79Published · Updated
Key facts
- Attack vector
- Local
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
svg-sanitizer is a SVG/XML sanitizer written in PHP. A cross-site scripting vulnerability impacts all users of the `svg-sanitizer` library prior to version 0.15.0. This issue is fixed in version 0.15.0. There is currently no workaround available.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00679 52nd percentileScored 2026-11-07
Fix Fixed svg-sanitizer (darylldoyle): 0.15.0enshrined/svg-sanitize (Packagist): 0.15.0
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| darylldoyle | svg-sanitizer | before 0.15.0 | 0.15.0 | Patch available | CNA |
| — | enshrined/svg-sanitize (Packagist) | before 0.15.0 | 0.15.0 | Patch available | GHSA-fqx8-v33p-4qcc |
- svg-sanitizer Vendordarylldoyle Affected before 0.15.0 Fixed in 0.15.0 Patch available CNA
- enshrined/svg-sanitize (Packagist) Vendor— Affected before 0.15.0 Fixed in 0.15.0 Patch available GHSA-fqx8-v33p-4qcc
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:svg-sanitizer_project:svg-sanitizer:*:*:*:*:*:*:*:* | before 0.15.0 | Vulnerable | Svg-sanitizer Project |
- cpe:2.3:a:svg-sanitizer_project:svg-sanitizer:*:*:*:*:*:*:*:* Versions before 0.15.0 Vulnerable ·Svg-sanitizer Project
Remediation
- Fix · CNA svg-sanitizer (darylldoyle) Fixed in 0.15.0
- Fix · GHSA-fqx8-v33p-4qcc enshrined/svg-sanitize (Packagist) Fixed in 0.15.0 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2022-23638
- 2026-10-03 Alias added: GHSA-fqx8-v33p-4qcc
References
Advisory 3
More darylldoyle vulnerabilities
- TI-2026-81116 Quadratic CPU exhaustion in svg-sanitizer PHP tag stripping CVSS 4.0HIGH 8.7
- TI-2026-84327 svg-sanitizer ReDoS and Fail-Open via image-set CSS Stripping CVSS 4.0HIGH 8.2
- TI-2026-74075 Mixed-case xlink:HrEf bypasses use nesting limit in svg-sanitizer CVSS 3.1MEDIUM 6.5
- TI-2026-69645 Denial of service in enshrined/svg-sanitize via crafted SVG DTD CVSS 3.1MEDIUM 6.5
- TI-2026-84328 Incomplete url() filtering in svg-sanitizer allows remote URL requests CVSS 4.0MEDIUM 5.3
- TI-2026-81115 darylldoyle svg-sanitizer CSS Injection and Remote Reference Bypass CVSS 4.0MEDIUM 5.1
Sources
- CVE-2022-23638 · CVE Program
- CVE-2022-23638 · NVD
- FIRST EPSS
- GHSA-fqx8-v33p-4qcc · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences