Cross-site scripting in HPE OneView
Priority LOW 28CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-79.
Summary
A remote cross-site scripting (xss) vulnerability was discovered in HPE OneView version(s): Prior to 6.6. HPE has provided a software update to resolve this vulnerability in HPE OneView.
Why it matters now
EPSS 0.00725 54th percentileScored 2026-11-07
Fix Fixed HPE OneView: 6.6
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | HPE OneView | before 6.6 | 6.6 | Patch available | CNA |
- HPE OneView Vendor— Affected before 6.6 Fixed in 6.6 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:hp:oneview:*:*:*:*:*:*:*:* | before 6.6 | Vulnerable | Hewlett Packard Enterprise |
- cpe:2.3:a:hp:oneview:*:*:*:*:*:*:*:* Versions before 6.6 Vulnerable ·Hewlett Packard Enterprise
Remediation
- Fix · CNA HPE OneView Fixed in 6.6
Timeline
- 2026-10-02 Threatist record created from CVE-2022-23697
- 2026-10-03 Alias added: GHSA-fxm9-49w7-pwfx
References
More Hewlett Packard Enterprise Oneview vulnerabilities
- TI-2023-14667 A remote authentication bypass issue exists in some OneView APIs. CVSS 3.1CRITICAL 9.8
- TI-2023-14666 A remote authentication bypass issue exists in a OneView API. CVSS 3.1CRITICAL 9.8
- TI-2022-11262 A remote bypass security restrictions vulnerability was discovered in HPE OneView… CVSS 3.1CRITICAL 9.8
- TI-2022-11261 Server-side request forgery in HPE OneView CVSS 3.1CRITICAL 9.8
- TI-2020-05810 There is a remote escalation of privilege possible for a malicious user that has a… CVSS 3.1HIGH 8.8
- TI-2023-27500 HPE OneView may allow command injection with local privilege escalation. CVSS 3.1HIGH 7.8
Sources
- CVE-2022-23697 · CVE Program
- CVE-2022-23697 · NVD
- FIRST EPSS
- GHSA-fxm9-49w7-pwfx · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences