Access control flaw in elasticsearch
Priority LOW 22CWE-264Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass, Privilege escalation
- Confidentiality · integrity · availability
- Low · None · None
- Fix status
- Partial Red Hat: 9 without a fix
Attack profile from CVSS 3.1 · NVD. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-264 and CWE-269.
Summary
A flaw was discovered in Elasticsearch 7.17.0’s upgrade assistant, in which upgrading from version 6.x to 7.x would disable the in-built protections on the security index, allowing authenticated users with “*” index permissions access to this index.
Why it matters now
EPSS 0.01035 64th percentileScored 2026-11-07
Fix Partial org.elasticsearch:elasticsearch (Maven): 7.17.1Red Hat: 9 without a fix
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Elastic | elasticsearch | Versions 7.16.0 through 7.17.0 | — | No fix listed | CNA |
| — | org.elasticsearch:elasticsearch (Maven) | 7.16.0 to before 7.17.1 | 7.17.1 | Patch available | GHSA-pgq6-ccqj-hpqr |
- elasticsearch VendorElastic Affected Versions 7.16.0 through 7.17.0 Fixed in — No fix listed CNA
- org.elasticsearch:elasticsearch (Maven) Vendor— Affected 7.16.0 to before 7.17.1 Fixed in 7.17.1 Patch available GHSA-pgq6-ccqj-hpqr
Remediation
- Fix · GHSA-pgq6-ccqj-hpqr org.elasticsearch:elasticsearch (Maven) Fixed in 7.17.1 Advisory →
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Logging Subsystem for Red Hat OpenShift | Affected | No fix planned: Will not fix |
| OpenShift Service Mesh 2.0 | Affected | No fix yet |
| OpenShift Service Mesh 2.1 | Affected | No fix planned: Will not fix |
| Red Hat JBoss Data Grid 6 | Affected | No fix planned: Out of support scope |
| Red Hat JBoss Fuse 6 | Affected | No fix planned: Out of support scope |
| Red Hat JBoss Fuse Service Works 6 | Affected | No fix planned: Out of support scope |
| Red Hat OpenShift Container Platform 3.11 | Affected | No fix planned: Will not fix |
| Red Hat OpenShift Container Platform 4 | Affected | No fix yet: Fix deferred |
| Red Hat OpenStack Platform 10 (Newton) | Affected | No fix planned: Out of support scope |
Not affected: 4 products
- Red Hat Decision Manager 7
- Red Hat Fuse 7
- Red Hat Integration Camel K 1
- Red Hat Process Automation 7
Timeline
- 2026-10-02 Threatist record created from CVE-2022-23708
- 2026-10-03 Alias added: GHSA-pgq6-ccqj-hpqr
References
More Elasticsearch vulnerabilities
- TI-2015-01295 The Groovy scripting engine in Elasticsearch before 1.3.8 and 1.4.x before 1.4.3 allows… KEVCVSS 3.1CRITICAL 9.8
- TI-2014-02491 The default configuration in Elasticsearch before 1.2 enables dynamic scripting, which… KEVCVSS 3.1HIGH 8.1
- TI-2023-15037 Elasticsearch StackOverflow vulnerability CVSS 3.1HIGH 7.5
- TI-2021-05135 Information disclosure in Elasticsearch CVSS 3.1MEDIUM 6.5
- TI-2021-05136 All versions of Elastic Cloud Enterprise has the Elasticsearch “anonymous” user enabled… CVSS 3.1HIGH 7.5
- TI-2015-04530 Elasticsearch before 1.6.1 allows remote attackers to execute arbitrary code via… CVSS 3.0CRITICAL 9.8
Sources
- CVE-2022-23708 · CVE Program
- CVE-2022-23708 · NVD
- FIRST EPSS
- GHSA-pgq6-ccqj-hpqr · GitHub Advisory Database · CC BY 4.0
- CVE-2022-23708 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences