Apache Pulsar Proxy target broker address isn't validated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA and GitHub.
Summary
Improper Input Validation vulnerability in Proxy component of Apache Pulsar allows an attacker to make TCP/IP connection attempts that originate from the Pulsar Proxy's IP address. When the Apache Pulsar Proxy component is used, it is possible to attempt to open TCP/IP connections to any IP address and port that the Pulsar Proxy can connect to. An attacker could use this as a way for DoS attacks that originate from the Pulsar Proxy's IP address. It hasn’t been detected that the Pulsar Proxy authentication can be bypassed. The attacker will have to have a valid token to a properly secured Pulsar Proxy. This issue affects Apache Pulsar Proxy versions 2.7.0 to 2.7.4; 2.8.0 to 2.8.2; 2.9.0 to 2.9.1; 2.6.4 and earlier.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Apache | Apache Pulsar | 2.7 – 2.7.4; 2.8 – 2.8.2; 2.9 – 2.9.1; 2.6 and earlier – 2.6.4 | — | No fix listed | CNA |
| — | org.apache.pulsar:pulsar (Maven) | before 2.7.5 | 2.7.5 | Patch available | GHSA-3mg9-m3f6-v7fq |
| — | org.apache.pulsar:pulsar (Maven) | 2.8.0 to before 2.8.3 | 2.8.3 | Patch available | GHSA-3mg9-m3f6-v7fq |
| — | org.apache.pulsar:pulsar (Maven) | 2.9.0 to before 2.9.2 | 2.9.2 | Patch available | GHSA-3mg9-m3f6-v7fq |
- Apache Pulsar VendorApache Affected 2.7 – 2.7.4; 2.8 – 2.8.2; 2.9 – 2.9.1; 2.6 and earlier – 2.6.4 Fixed in — No fix listed CNA
- org.apache.pulsar:pulsar (Maven) Vendor— Affected before 2.7.5 Fixed in 2.7.5 Patch available GHSA-3mg9-m3f6-v7fq
- org.apache.pulsar:pulsar (Maven) Vendor— Affected 2.8.0 to before 2.8.3 Fixed in 2.8.3 Patch available GHSA-3mg9-m3f6-v7fq
- org.apache.pulsar:pulsar (Maven) Vendor— Affected 2.9.0 to before 2.9.2 Fixed in 2.9.2 Patch available GHSA-3mg9-m3f6-v7fq
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:apache:pulsar:*:*:*:*:*:*:*:* | up to 2.6.4; 2.7.0 to before 2.7.5; 2.8.0 to before 2.8.3; 2.9.0 to before 2.9.2 | Vulnerable | Apache |
- cpe:2.3:a:apache:pulsar:*:*:*:*:*:*:*:* Versions up to 2.6.4; 2.7.0 to before 2.7.5; 2.8.0 to before 2.8.3; 2.9.0 to before 2.9.2 Vulnerable ·Apache
Remediation
- Fix · GHSA-3mg9-m3f6-v7fq org.apache.pulsar:pulsar (Maven) Fixed in 2.7.5 Advisory →
- Fix · GHSA-3mg9-m3f6-v7fq org.apache.pulsar:pulsar (Maven) Fixed in 2.8.3 Advisory →
- Fix · GHSA-3mg9-m3f6-v7fq org.apache.pulsar:pulsar (Maven) Fixed in 2.9.2 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2022-24280
- 2026-10-03 Alias added: GHSA-3mg9-m3f6-v7fq
References
More Apache Pulsar vulnerabilities
- TI-2024-18155 Apache Pulsar: Pulsar Functions Worker's Archive Extraction Vulnerability Allows Unauthorized File Modification CVSS 3.1CRITICAL 9.9
- TI-2021-05150 Authentication with JWT allows use of “none”-algorithm CVSS 3.1CRITICAL 9.8
- TI-2024-17990 Apache Pulsar: Improper Input Validation in Pulsar Function Worker allows Remote Code Execution CVSS 3.1CRITICAL 9.9
- TI-2023-14272 Apache Pulsar: Incorrect Authorization for Function Worker when using mTLS Authentication through Pulsar Proxy CVSS 3.1CRITICAL 9.6
- TI-2022-15232 Apache Pulsar: Improper Authentication for Pulsar Proxy Statistics Endpoint CVSS 3.1HIGH 8.2
- TI-2024-18500 Apache Pulsar: Pulsar Functions Worker Allows Unauthorized File Access and Unauthorized HTTP/HTTPS Proxying CVSS 3.1HIGH 8.8
Sources
- CVE-2022-24280 · CVE Program
- CVE-2022-24280 · NVD
- FIRST EPSS
- GHSA-3mg9-m3f6-v7fq · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences