Remote code execution in mybb
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-94.
Summary
MyBB is a free and open source forum software. In affected versions the Admin CP's Settings management module does not validate setting types correctly on insertion and update, making it possible to add settings of supported type `php` with PHP code, executed on on _Change Settings_ pages. This results in a Remote Code Execution (RCE) vulnerability. The vulnerable module requires Admin CP access with the `Can manage settings?` permission. MyBB's Settings module, which allows administrators to add, edit, and delete non-default settings, stores setting data in an options code string ($options_code; mybb_settings.optionscode database column) that identifies the setting type and its options, separated by a new line character (\n). In MyBB 1.2.0, support for setting type php was added, for which the remaining part of the options code is PHP code executed on Change Settings pages (reserved for plugins and internal use). MyBB 1.8.30 resolves this issue. There are no known workarounds.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
Remediation
- Fix · CNA mybb (mybb) Fixed in 1.8.30
Timeline
- 2026-10-02 Threatist record created from CVE-2022-24734
References
Exploit 2
Patch 2
More Mybb vulnerabilities
- TI-2011-04621 myBB 1.6.4 Backdoor Arbitrary Command Execution CVSS 4.0CRITICAL 10.0
- TI-2023-21959 MyBB before 1.8.36 allows Code Injection by users with certain high privileges. CVSS 3.1HIGH 7.2
- TI-2022-18641 Mail settings' command parameter injection in mybb CVSS 3.1HIGH 7.2
- TI-2025-21092 An issue in MyBB 1.8.38 allows a remote attacker to obtain sensitive information via the… CVSS 3.1HIGH 7.6
- TI-2025-21091 An issue in MyBB 1.8.38 allows a remote attacker to obtain sensitive information via the… CVSS 3.1HIGH 7.6
- TI-2025-21090 An issue in MyBB 1.8.38 allows a remote attacker to obtain sensitive information via the… CVSS 3.1HIGH 7.6
Sources
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences