Read the docs
TI-2022-18641 Aliases CVE-2022-39265

Mail settings' command parameter injection in mybb

Priority HIGH 67CWE-74Published · Updated

Key facts

Attack vector
Network
Privileges required
High
User interaction
None
Attack complexity
Low
Impact type
Code execution
Confidentiality · integrity · availability
High · High · High
Fix status
Fixed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-77.

Summary

MyBB is a free and open source forum software. The _Mail Settings_ → Additional Parameters for PHP's mail() function mail_parameters setting value, in connection with the configured mail program's options and behavior, may allow access to sensitive information and Remote Code Execution (RCE). The vulnerable module requires Admin CP access with the `_Can manage settings?_` permission and may depend on configured file permissions. MyBB 1.8.31 resolves this issue with the commit `0cd318136a`. Users are advised to upgrade. There are no known workarounds for this vulnerability.

Why it matters now

Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.03107 87th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed mybb (mybb): 1.8.31

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
Poc
Automatable
No
Technical impact
Total

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
mybbmybbbefore 1.8.311.8.31Patch availableCNA
  • mybb Vendormybb Affected before 1.8.31 Fixed in 1.8.31 Patch available CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:mybb:mybb:*:*:*:*:*:*:*:*before 1.8.31Vulnerablemybb
  • cpe:2.3:a:mybb:mybb:*:*:*:*:*:*:*:* Versions before 1.8.31 Vulnerable ·mybb

Remediation

  • Fix · CNA mybb (mybb) Fixed in 1.8.31

Timeline

  1. 2026-10-02 Threatist record created from CVE-2022-39265

References

  • TI-2011-04621 myBB 1.6.4 Backdoor Arbitrary Command Execution CVSS 4.0CRITICAL 10.0
  • TI-2022-08548 Remote code execution in mybb CVSS 3.1HIGH 7.2
  • TI-2023-21959 MyBB before 1.8.36 allows Code Injection by users with certain high privileges. CVSS 3.1HIGH 7.2
  • TI-2025-21092 An issue in MyBB 1.8.38 allows a remote attacker to obtain sensitive information via the… CVSS 3.1HIGH 7.6
  • TI-2025-21091 An issue in MyBB 1.8.38 allows a remote attacker to obtain sensitive information via the… CVSS 3.1HIGH 7.6
  • TI-2025-21090 An issue in MyBB 1.8.38 allows a remote attacker to obtain sensitive information via the… CVSS 3.1HIGH 7.6
See all 139 →

Sources

This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences