Read the docs
TI-2022-08607 Aliases CVE-2022-24794GHSA-7p99-3798-f85c

Open Redirect in express-openid-connect

Priority LOW 34CWE-601Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
High
Impact type
Spoofing
Confidentiality · integrity · availability
High · Low · None
Fix status
Fixed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-601.

Summary

Express OpenID Connect is an Express JS middleware implementing sign on for Express web apps using OpenID Connect. Users of the `requiresAuth` middleware, either directly or through the default `authRequired` option, are vulnerable to an Open Redirect when the middleware is applied to a catch all route. If all routes under `example.com` are protected with the `requiresAuth` middleware, a visit to `http://example.com//google.com` will be redirected to `google.com` after login because the original url reported by the Express framework is not properly sanitized. This vulnerability affects versions prior to 2.7.2. Users are advised to upgrade. There are no known workarounds.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00738 54th percentileScored 2026-11-07
Fix Fixed express-openid-connect (auth0): 2.7.2express-openid-connect (npm): 2.7.2

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
auth0express-openid-connectbefore 2.7.22.7.2Patch availableCNA
—express-openid-connect (npm)before 2.7.22.7.2Patch availableGHSA-7p99-3798-f85c
  • express-openid-connect Vendorauth0 Affected before 2.7.2 Fixed in 2.7.2 Patch available CNA
  • express-openid-connect (npm) Vendor— Affected before 2.7.2 Fixed in 2.7.2 Patch available GHSA-7p99-3798-f85c

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:auth0:express_openid_connect:*:*:*:*:*:node.js:*:*before 2.7.2Vulnerableauth0
  • cpe:2.3:a:auth0:express_openid_connect:*:*:*:*:*:node.js:*:* Versions before 2.7.2 Vulnerable ·auth0

Remediation

  • Fix · CNA express-openid-connect (auth0) Fixed in 2.7.2
  • Fix · GHSA-7p99-3798-f85c express-openid-connect (npm) Fixed in 2.7.2 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2022-24794
  2. 2026-10-03 Alias added: GHSA-7p99-3798-f85c

References

  • TI-2021-18081 Session fixation in express-openid-connect CVSS 3.1HIGH 8.8

Sources