Symfony vulnerable to Session Fixation of CSRF tokens
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Spoofing, Security bypass
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-384 and CWE-613.
Summary
Symfony is a PHP framework for web and console applications and a set of reusable PHP components. When authenticating users Symfony by default regenerates the session ID upon login, but preserves the rest of session attributes. Because this does not clear CSRF tokens upon login, this might enables same-site attackers to bypass the CSRF protection mechanism by performing an attack similar to a session-fixation. This issue has been fixed in the 4.4 branch.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| symfony | symfony | 2.0.0 to before 4.4.50; 5.0.0 to before 5.4.20; 6.0.0 to before 6.0.20; 6.1.0 to before 6.1.12; 6.2.0 to before 6.2.6 | 4.4.50, 5.4.20, 6.0.20, 6.1.12, 6.2.6 | Patch available | CNA |
| — | symfony/security-bundle (Packagist) | 2.0.0 to before 4.4.50 | 4.4.50 | Patch available | GHSA-3gv2-29qc-v67m |
| — | symfony/security-bundle (Packagist) | 5.0.0 to before 5.4.20 | 5.4.20 | Patch available | GHSA-3gv2-29qc-v67m |
| — | symfony/security-bundle (Packagist) | 6.0.0 to before 6.0.20 | 6.0.20 | Patch available | GHSA-3gv2-29qc-v67m |
| — | symfony/security-bundle (Packagist) | 6.1.0 to before 6.1.12 | 6.1.12 | Patch available | GHSA-3gv2-29qc-v67m |
| — | symfony/security-bundle (Packagist) | 6.2.0 to before 6.2.6 | 6.2.6 | Patch available | GHSA-3gv2-29qc-v67m |
| — | symfony/symfony (Packagist) | 2.0.0 to before 4.4.50 | 4.4.50 | Patch available | GHSA-3gv2-29qc-v67m |
| — | symfony/symfony (Packagist) | 5.0.0 to before 5.4.20 | 5.4.20 | Patch available | GHSA-3gv2-29qc-v67m |
| — | symfony/symfony (Packagist) | 6.0.0 to before 6.0.20 | 6.0.20 | Patch available | GHSA-3gv2-29qc-v67m |
| — | symfony/symfony (Packagist) | 6.1.0 to before 6.1.12 | 6.1.12 | Patch available | GHSA-3gv2-29qc-v67m |
| — | symfony/symfony (Packagist) | 6.2.0 to before 6.2.6 | 6.2.6 | Patch available | GHSA-3gv2-29qc-v67m |
- symfony Vendorsymfony Affected 2.0.0 to before 4.4.50; 5.0.0 to before 5.4.20; 6.0.0 to before 6.0.20; 6.1.0 to before 6.1.12; 6.2.0 to before 6.2.6 Fixed in 4.4.50, 5.4.20, 6.0.20, 6.1.12, 6.2.6 Patch available CNA
- symfony/security-bundle (Packagist) Vendor— Affected 2.0.0 to before 4.4.50 Fixed in 4.4.50 Patch available GHSA-3gv2-29qc-v67m
- symfony/security-bundle (Packagist) Vendor— Affected 5.0.0 to before 5.4.20 Fixed in 5.4.20 Patch available GHSA-3gv2-29qc-v67m
- symfony/security-bundle (Packagist) Vendor— Affected 6.0.0 to before 6.0.20 Fixed in 6.0.20 Patch available GHSA-3gv2-29qc-v67m
- symfony/security-bundle (Packagist) Vendor— Affected 6.1.0 to before 6.1.12 Fixed in 6.1.12 Patch available GHSA-3gv2-29qc-v67m
- symfony/security-bundle (Packagist) Vendor— Affected 6.2.0 to before 6.2.6 Fixed in 6.2.6 Patch available GHSA-3gv2-29qc-v67m
- symfony/symfony (Packagist) Vendor— Affected 2.0.0 to before 4.4.50 Fixed in 4.4.50 Patch available GHSA-3gv2-29qc-v67m
- symfony/symfony (Packagist) Vendor— Affected 5.0.0 to before 5.4.20 Fixed in 5.4.20 Patch available GHSA-3gv2-29qc-v67m
- symfony/symfony (Packagist) Vendor— Affected 6.0.0 to before 6.0.20 Fixed in 6.0.20 Patch available GHSA-3gv2-29qc-v67m
- symfony/symfony (Packagist) Vendor— Affected 6.1.0 to before 6.1.12 Fixed in 6.1.12 Patch available GHSA-3gv2-29qc-v67m
- symfony/symfony (Packagist) Vendor— Affected 6.2.0 to before 6.2.6 Fixed in 6.2.6 Patch available GHSA-3gv2-29qc-v67m
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:sensiolabs:symfony:*:*:*:*:*:*:*:* | 2.0.0 to before 4.4.50; 5.0.0 to before 5.4.20; 6.0.0 to before 6.0.20; 6.1.0 to before 6.1.12; 6.2.0 to before 6.2.6 | Vulnerable | sensiolabs |
- cpe:2.3:a:sensiolabs:symfony:*:*:*:*:*:*:*:* Versions 2.0.0 to before 4.4.50; 5.0.0 to before 5.4.20; 6.0.0 to before 6.0.20; 6.1.0 to before 6.1.12; 6.2.0 to before 6.2.6 Vulnerable ·sensiolabs
Remediation
- Fix · CNA symfony (symfony) Fixed in 4.4.50, 5.4.20, 6.0.20, 6.1.12, 6.2.6
- Fix · GHSA-3gv2-29qc-v67m symfony/security-bundle (Packagist) Fixed in 4.4.50 Advisory →
- Fix · GHSA-3gv2-29qc-v67m symfony/security-bundle (Packagist) Fixed in 5.4.20 Advisory →
- Fix · GHSA-3gv2-29qc-v67m symfony/security-bundle (Packagist) Fixed in 6.0.20 Advisory →
- Fix · GHSA-3gv2-29qc-v67m symfony/security-bundle (Packagist) Fixed in 6.1.12 Advisory →
- Fix · GHSA-3gv2-29qc-v67m symfony/security-bundle (Packagist) Fixed in 6.2.6 Advisory →
- Fix · GHSA-3gv2-29qc-v67m symfony/symfony (Packagist) Fixed in 4.4.50 Advisory →
- Fix · GHSA-3gv2-29qc-v67m symfony/symfony (Packagist) Fixed in 5.4.20 Advisory →
- Fix · GHSA-3gv2-29qc-v67m symfony/symfony (Packagist) Fixed in 6.0.20 Advisory →
- Fix · GHSA-3gv2-29qc-v67m symfony/symfony (Packagist) Fixed in 6.1.12 Advisory →
- Fix · GHSA-3gv2-29qc-v67m symfony/symfony (Packagist) Fixed in 6.2.6 Advisory →
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2022-24895
- 2026-10-03 Alias added: GHSA-3gv2-29qc-v67m
References
Patch 3
Other 5
- https://github.com/FriendsOfPHP/security-advisories/blob/master/symfony/security-bundle/CVE-2022-24895.yaml
- https://lists.debian.org/debian-lts-announce/2023/07/msg00014.html
- https://github.com/FriendsOfPHP/security-advisories/blob/master/symfony/symfony/CVE-2022-24895.yaml
- https://github.com/symfony/symfony
- https://symfony.com/cve-2022-24895
More symfony vulnerabilities
- TI-2024-33775 Ability to change environment from query in symfony/runtime CVSS 3.1HIGH 7.3
- TI-2026-34283 Twig: The `spaceless` filter implicitly marks its output as safe CVSS 4.0MEDIUM 5.1
- TI-2022-07667 Code injection in Twig CVSS 3.1CRITICAL 9.8
- TI-2018-10028 Twig before 2.4.4 allows Server-Side Template Injection (SSTI) via the search search_key… CVSS 3.0CRITICAL 9.8
- TI-2026-35851 Incorrect authorization in symfony CVSS 4.0HIGH 8.7
- TI-2026-35264 Improper input validation in symfony CVSS 4.0HIGH 8.3
Sources
- CVE-2022-24895 · CVE Program
- CVE-2022-24895 · NVD
- FIRST EPSS
- GHSA-3gv2-29qc-v67m · GitHub Advisory Database · CC BY 4.0
- CVE-2022-24895 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences