Authentication bypass and denial of service (DoS) vulnerabilities in Apple Game Center auth adapter
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass, Spoofing
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-287 and CWE-295.
Summary
Improper validation of the Apple certificate URL in the Apple Game Center authentication adapter allows attackers to bypass authentication, making the server vulnerable to DoS attacks. The vulnerability has been fixed by improving the URL validation and adding additional checks of the resource the URL points to before downloading it.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| parse-community | parse-server | before 4.10.10; 5.0.0 to before 5.2.1 | 4.10.10, 5.2.1 | Patch available | CNA |
| — | parse-server (npm) | before 4.10.10 | 4.10.10 | Patch available | GHSA-qf8x-vqjv-92gr |
| — | parse-server (npm) | 5.0.0 to before 5.2.1 | 5.2.1 | Patch available | GHSA-qf8x-vqjv-92gr |
- parse-server Vendorparse-community Affected before 4.10.10; 5.0.0 to before 5.2.1 Fixed in 4.10.10, 5.2.1 Patch available CNA
- parse-server (npm) Vendor— Affected before 4.10.10 Fixed in 4.10.10 Patch available GHSA-qf8x-vqjv-92gr
- parse-server (npm) Vendor— Affected 5.0.0 to before 5.2.1 Fixed in 5.2.1 Patch available GHSA-qf8x-vqjv-92gr
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:parseplatform:parse-server:*:*:*:*:*:node.js:*:* | before 4.10.10; 5.0.0 to before 5.2.1 | Vulnerable | parse-community |
- cpe:2.3:a:parseplatform:parse-server:*:*:*:*:*:node.js:*:* Versions before 4.10.10; 5.0.0 to before 5.2.1 Vulnerable ·parse-community
Remediation
- Fix · CNA parse-server (parse-community) Fixed in 4.10.10, 5.2.1
- Fix · GHSA-qf8x-vqjv-92gr parse-server (npm) Fixed in 4.10.10 Advisory →
- Fix · GHSA-qf8x-vqjv-92gr parse-server (npm) Fixed in 5.2.1 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2022-24901
- 2026-10-03 Alias added: GHSA-qf8x-vqjv-92gr
References
More parse-community Parse-server vulnerabilities
- TI-2022-08574 Command Injection in Parse server CVSS 3.1CRITICAL 10.0
- TI-2024-18136 Parse Server literalizeRegexPart SQL Injection CVSS 3.1CRITICAL 10.0
- TI-2022-18768 Parse Server vulnerable to Remote Code Execution via prototype pollution in MongoDB BSON parser CVSS 3.1CRITICAL 9.8
- TI-2024-31550 Parse Server's custom object ID allows to acquire role privileges CVSS 3.1HIGH 8.1
- TI-2023-18316 Parse Server vulnerable to remote code execution via MongoDB BSON parser through prototype pollution CVSS 3.1CRITICAL 9.8
- TI-2026-23790 Parse Server session token exfiltration via `redirectClassNameForKey` query parameter CVSS 4.0CRITICAL 9.9
Sources
- CVE-2022-24901 · CVE Program
- CVE-2022-24901 · NVD
- FIRST EPSS
- GHSA-qf8x-vqjv-92gr · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences