Cross-site scripting (XSS) in whoogle-search
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
The package whoogle-search before 0.7.2 are vulnerable to Cross-site Scripting (XSS) via the query string parameter q. In the case where it does not contain the http string, it is used to build the error_message that is then rendered in the error.html template, using the [flask.render_template](https://flask.palletsprojects.com/en/2.1.x/api/flask.render_template) function. However, the error_message is rendered using the [| safe filter](https://jinja.palletsprojects.com/en/3.1.x/templates/working-with-automatic-escaping), meaning the user input is not escaped.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | whoogle-search | before 0.7.2 | 0.7.2 | Patch available | CNA |
| — | whoogle-search (PyPI) | before 0.7.2 | 0.7.2 | Patch available | GHSA-mxvc-fwgx-j778 |
- whoogle-search Vendor— Affected before 0.7.2 Fixed in 0.7.2 Patch available CNA
- whoogle-search (PyPI) Vendor— Affected before 0.7.2 Fixed in 0.7.2 Patch available GHSA-mxvc-fwgx-j778
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:whoogle-search_project:whoogle-search:*:*:*:*:*:*:*:* | before 0.7.2 | Vulnerable | Whoogle-search Project |
- cpe:2.3:a:whoogle-search_project:whoogle-search:*:*:*:*:*:*:*:* Versions before 0.7.2 Vulnerable ·Whoogle-search Project
Remediation
- Fix · CNA whoogle-search Fixed in 0.7.2
- Fix · GHSA-mxvc-fwgx-j778 whoogle-search (PyPI) Fixed in 0.7.2 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2022-25303
- 2026-10-03 Alias added: GHSA-mxvc-fwgx-j778
References
Advisory 2
Sources
- CVE-2022-25303 · CVE Program
- CVE-2022-25303 · NVD
- FIRST EPSS
- GHSA-mxvc-fwgx-j778 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences