Cross-site scripting in Mautic
Priority HIGH 77CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- High · High · Low
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
A cross-site scripting (XSS) vulnerability in the web tracking component of Mautic before 4.3.0 allows remote attackers to inject executable javascript
Why it matters now
EPSS 0.63036 99th percentileScored 2026-11-07
Fix Fixed Mautic (Mautic): 4.3.0mautic/core (Packagist): 4.3.0
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Mautic | Mautic | before 4.3.0 | 4.3.0 | Patch available | CNA |
| — | mautic/core (Packagist) | before 4.3.0 | 4.3.0 | Patch available | GHSA-pjpc-87mp-4332 |
- Mautic VendorMautic Affected before 4.3.0 Fixed in 4.3.0 Patch available CNA
- mautic/core (Packagist) Vendor— Affected before 4.3.0 Fixed in 4.3.0 Patch available GHSA-pjpc-87mp-4332
Remediation
- Fix · CNA Mautic (Mautic) Fixed in 4.3.0
- Fix · GHSA-pjpc-87mp-4332 mautic/core (Packagist) Fixed in 4.3.0 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2022-25772
- 2026-10-03 Alias added: GHSA-pjpc-87mp-4332
References
Advisory 2
More Mautic vulnerabilities
- TI-2024-02543 Predictable Page Indexing Might Lead to Sensitive Data Exposure in Mautic CVSS 3.1MEDIUM 5.3
- TI-2024-02544 Improper Access Control Issues Lead to Sensitive Data Exposure in Mautic CVSS 3.1MEDIUM 5.4
- TI-2024-03218 Improper Access Control Leads to Server-Side Request Forgery in Mautic CVSS 3.1MEDIUM 5.0
- TI-2024-31435 Remote Code Execution & File Deletion in Asset Uploads CVSS 3.1CRITICAL 9.9
- TI-2018-05847 Mautic before 2.13.0 allows CSV injection. CVSS 3.0CRITICAL 9.8
- TI-2022-09342 Improper regex in htaccess file CVSS 3.1CRITICAL 9.1
Sources
- CVE-2022-25772 · CVE Program
- CVE-2022-25772 · NVD
- FIRST EPSS
- GHSA-pjpc-87mp-4332 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences