Cross-site scripting (XSS) in vuetify
Priority LOW 26CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
The package vuetify from 2.0.0-beta.4 and before 2.6.10 are vulnerable to Cross-site Scripting (XSS) due to improper input sanitization in the 'eventName' function within the VCalendar component.
Why it matters now
EPSS 0.00873 59th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed vuetify: 2.6.10vuetify (npm): 2.6.10+1 more product
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | vuetify | 2.0.0-beta.4 and later; before 2.6.10 | 2.6.10 | Patch available | CNA |
| — | vuetify (npm) | 2.0.0-beta.4 to before 2.6.10 | 2.6.10 | Patch available | GHSA-q4q5-c5cv-2p68 |
| — | org.webjars.npm:vuetify (Maven) | 2.0.0-beta.4 to before 2.6.10 | 2.6.10 | Patch available | GHSA-q4q5-c5cv-2p68 |
- vuetify Vendor— Affected 2.0.0-beta.4 and later; before 2.6.10 Fixed in 2.6.10 Patch available CNA
- vuetify (npm) Vendor— Affected 2.0.0-beta.4 to before 2.6.10 Fixed in 2.6.10 Patch available GHSA-q4q5-c5cv-2p68
- org.webjars.npm:vuetify (Maven) Vendor— Affected 2.0.0-beta.4 to before 2.6.10 Fixed in 2.6.10 Patch available GHSA-q4q5-c5cv-2p68
CPE configurations NVD · 7
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:vuetifyjs:vuetify:*:*:*:*:*:*:*:* | 2.0.1 to before 2.6.10 | Vulnerable | Vuetifyjs |
| cpe:2.3:a:vuetifyjs:vuetify:2.0.0:beta4:*:*:*:*:*:* | 2.0.0 beta4 | Vulnerable | Vuetifyjs |
| cpe:2.3:a:vuetifyjs:vuetify:2.0.0:beta5:*:*:*:*:*:* | 2.0.0 beta5 | Vulnerable | Vuetifyjs |
| cpe:2.3:a:vuetifyjs:vuetify:2.0.0:beta6:*:*:*:*:*:* | 2.0.0 beta6 | Vulnerable | Vuetifyjs |
| cpe:2.3:a:vuetifyjs:vuetify:2.0.0:beta7:*:*:*:*:*:* | 2.0.0 beta7 | Vulnerable | Vuetifyjs |
| cpe:2.3:a:vuetifyjs:vuetify:2.0.0:beta8:*:*:*:*:*:* | 2.0.0 beta8 | Vulnerable | Vuetifyjs |
| cpe:2.3:a:vuetifyjs:vuetify:2.0.0:beta9:*:*:*:*:*:* | 2.0.0 beta9 | Vulnerable | Vuetifyjs |
- cpe:2.3:a:vuetifyjs:vuetify:*:*:*:*:*:*:*:* Versions 2.0.1 to before 2.6.10 Vulnerable ·Vuetifyjs
- cpe:2.3:a:vuetifyjs:vuetify:2.0.0:beta4:*:*:*:*:*:* Versions 2.0.0 beta4 Vulnerable ·Vuetifyjs
- cpe:2.3:a:vuetifyjs:vuetify:2.0.0:beta5:*:*:*:*:*:* Versions 2.0.0 beta5 Vulnerable ·Vuetifyjs
- cpe:2.3:a:vuetifyjs:vuetify:2.0.0:beta6:*:*:*:*:*:* Versions 2.0.0 beta6 Vulnerable ·Vuetifyjs
- cpe:2.3:a:vuetifyjs:vuetify:2.0.0:beta7:*:*:*:*:*:* Versions 2.0.0 beta7 Vulnerable ·Vuetifyjs
- cpe:2.3:a:vuetifyjs:vuetify:2.0.0:beta8:*:*:*:*:*:* Versions 2.0.0 beta8 Vulnerable ·Vuetifyjs
- cpe:2.3:a:vuetifyjs:vuetify:2.0.0:beta9:*:*:*:*:*:* Versions 2.0.0 beta9 Vulnerable ·Vuetifyjs
Remediation
- Fix · CNA vuetify Fixed in 2.6.10
- Fix · GHSA-q4q5-c5cv-2p68 vuetify (npm) Fixed in 2.6.10 Advisory →
- Fix · GHSA-q4q5-c5cv-2p68 org.webjars.npm:vuetify (Maven) Fixed in 2.6.10 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2022-25873
- 2026-10-03 Alias added: GHSA-q4q5-c5cv-2p68
References
Sources
- CVE-2022-25873 · CVE Program
- CVE-2022-25873 · NVD
- FIRST EPSS
- GHSA-q4q5-c5cv-2p68 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences