OS command injection in exec-local-bin
Priority HIGH 76CWE-78Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-78.
Summary
Versions of the package exec-local-bin before 1.2.0 are vulnerable to Command Injection via the theProcess() functionality due to improper user-input sanitization.
Why it matters now
Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.0261 85th percentileScored 2026-11-07
Fix Fixed exec-local-bin: 1.2.0exec-local-bin (npm): 1.2.0
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | exec-local-bin | before 1.2.0 | 1.2.0 | Patch available | CNA |
| — | exec-local-bin (npm) | before 1.2.0 | 1.2.0 | Patch available | GHSA-f259-h6m8-hm8m |
- exec-local-bin Vendor— Affected before 1.2.0 Fixed in 1.2.0 Patch available CNA
- exec-local-bin (npm) Vendor— Affected before 1.2.0 Fixed in 1.2.0 Patch available GHSA-f259-h6m8-hm8m
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:exec-local-bin_project:exec-local-bin:*:*:*:*:*:node.js:*:* | before 1.2.0 | Vulnerable | Exec-local-bin Project |
- cpe:2.3:a:exec-local-bin_project:exec-local-bin:*:*:*:*:*:node.js:*:* Versions before 1.2.0 Vulnerable ·Exec-local-bin Project
Remediation
- Fix · CNA exec-local-bin Fixed in 1.2.0
- Fix · GHSA-f259-h6m8-hm8m exec-local-bin (npm) Fixed in 1.2.0 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2022-25923
- 2026-10-03 Alias added: GHSA-f259-h6m8-hm8m
References
Sources
- CVE-2022-25923 · CVE Program
- CVE-2022-25923 · NVD
- FIRST EPSS
- GHSA-f259-h6m8-hm8m · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences