Cross-site scripting in github.com/usememos/memos/server
Priority MEDIUM 60CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
All versions of the package github.com/usememos/memos/server are vulnerable to Cross-site Scripting (XSS) due to insufficient checks on external resources, which allows malicious actors to introduce links starting with a javascript: scheme.
Why it matters now
Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00534 45th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed github.com/usememos/memos (Go): 0.10.4-0.20230211093429-b11d2130a084
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | github.com/usememos/memos/server | all versions | — | No fix listed | CNA |
| — | github.com/usememos/memos (Go) | before 0.10.4-0.20230211093429-b11d2130a084 | 0.10.4-0.20230211093429-b11d2130a084 | Patch available | GHSA-9w8x-5hv5-r6gw |
- github.com/usememos/memos/server Vendor— Affected all versions Fixed in — No fix listed CNA
- github.com/usememos/memos (Go) Vendor— Affected before 0.10.4-0.20230211093429-b11d2130a084 Fixed in 0.10.4-0.20230211093429-b11d2130a084 Patch available GHSA-9w8x-5hv5-r6gw
Remediation
- Fix · GHSA-9w8x-5hv5-r6gw github.com/usememos/memos (Go) Fixed in 0.10.4-0.20230211093429-b11d2130a084 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2022-25978
- 2026-10-03 Alias added: GHSA-9w8x-5hv5-r6gw
References
More usememos Memos vulnerabilities
- TI-2025-32234 The Memos application, up to version v0.24.3, allows for the embedding of markdown images… CVSS 3.1CRITICAL 9.8
- TI-2025-16796 elestio memos v0.23.0 is vulnerable to Server-Side Request Forgery (SSRF) due to… CVSS 3.1CRITICAL 9.8
- TI-2023-04328 Improper Access Control in usememos/memos CVSS 3.1CRITICAL 9.8
- TI-2022-04459 Cross-site Scripting (XSS) - Stored in usememos/memos CVSS 3.1CRITICAL 9.0
- TI-2022-04458 Cross-site Scripting (XSS) - Stored in usememos/memos CVSS 3.1CRITICAL 9.0
- TI-2022-04283 Authorization Bypass Through User-Controlled Key in usememos/memos CVSS 3.1CRITICAL 9.8
Sources
- CVE-2022-25978 · CVE Program
- CVE-2022-25978 · NVD
- FIRST EPSS
- GHSA-9w8x-5hv5-r6gw · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences