Read the docs
TI-2022-09496 Aliases CVE-2022-25979GHSA-r4hg-4cpq-q57c

Cross-site scripting in jsuites

Priority MEDIUM 60CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
Required
Attack complexity
Low
Impact type
Cross-site scripting
Confidentiality · integrity · availability
Low · Low · None
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.

Summary

Versions of the package jsuites before 5.0.1 are vulnerable to Cross-site Scripting (XSS) due to improper user-input sanitization in the Editor() function.

Why it matters now

Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00617 49th percentileScored 2026-11-07
Fix Fixed jsuites: 5.0.1jsuites (npm): 5.0.1

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
Poc
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
—jsuitesbefore 5.0.15.0.1Patch availableCNA
—org.webjars.npm:jsuitesall versions—No fix listedCNA
—jsuites (npm)before 5.0.15.0.1Patch availableGHSA-r4hg-4cpq-q57c
  • jsuites Vendor— Affected before 5.0.1 Fixed in 5.0.1 Patch available CNA
  • org.webjars.npm:jsuites Vendor— Affected all versions Fixed in — No fix listed CNA
  • jsuites (npm) Vendor— Affected before 5.0.1 Fixed in 5.0.1 Patch available GHSA-r4hg-4cpq-q57c

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:jsuites:jsuites:*:*:*:*:*:*:*:*before 5.0.1Vulnerablejsuites
  • cpe:2.3:a:jsuites:jsuites:*:*:*:*:*:*:*:* Versions before 5.0.1 Vulnerable ·jsuites

Remediation

  • Fix · CNA jsuites Fixed in 5.0.1
  • Fix · GHSA-r4hg-4cpq-q57c jsuites (npm) Fixed in 5.0.1 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2022-25979
  2. 2026-10-03 Alias added: GHSA-r4hg-4cpq-q57c

References

Sources