Read the docs
TI-2022-10940 Aliases CVE-2022-28142GHSA-fhhx-r983-44xc

Improper certificate validation in Jenkins Proxmox Plugin

Priority LOW 34CWE-295Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
Spoofing
Confidentiality · integrity · availability
None · High · None
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-295.

Summary

Jenkins Proxmox Plugin 0.6.0 and earlier disables SSL/TLS certificate validation globally for the Jenkins controller JVM when configured to ignore SSL/TLS issues.

Why it matters now

EPSS 0.00668 52nd percentileScored 2026-11-07
Fix Fixed org.jenkins-ci.plugins:proxmox (Maven): 0.7.0

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
JenkinsJenkins Proxmox Pluginup to 0.6.0—No fix listedCNA
—org.jenkins-ci.plugins:proxmox (Maven)before 0.7.00.7.0Patch availableGHSA-fhhx-r983-44xc
  • Jenkins Proxmox Plugin VendorJenkins Affected up to 0.6.0 Fixed in — No fix listed CNA
  • org.jenkins-ci.plugins:proxmox (Maven) Vendor— Affected before 0.7.0 Fixed in 0.7.0 Patch available GHSA-fhhx-r983-44xc

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:jenkins:proxmox:*:*:*:*:*:jenkins:*:*up to 0.6.0VulnerableJenkins
  • cpe:2.3:a:jenkins:proxmox:*:*:*:*:*:jenkins:*:* Versions up to 0.6.0 Vulnerable ·Jenkins

Remediation

  • Fix · GHSA-fhhx-r983-44xc org.jenkins-ci.plugins:proxmox (Maven) Fixed in 0.7.0 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2022-28142
  2. 2026-10-03 Alias added: GHSA-fhhx-r983-44xc

References

  • TI-2022-10939 Insufficiently protected credentials in Jenkins Proxmox Plugin CVSS 3.1MEDIUM 6.5
  • TI-2022-10942 Missing authorization in Jenkins Proxmox Plugin CVSS 3.1MEDIUM 6.5
  • TI-2022-10941 Cross-site request forgery in Jenkins Proxmox Plugin CVSS 3.1MEDIUM 6.5

Sources