Read the docs
TI-2022-10941 Aliases CVE-2022-28143GHSA-wjvr-2hjg-6rhj

Cross-site request forgery in Jenkins Proxmox Plugin

Priority LOW 30CWE-352Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
None
Attack complexity
Low
Impact type
Tampering
Confidentiality · integrity · availability
None · High · None
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-352.

Summary

A cross-site request forgery (CSRF) vulnerability in Jenkins Proxmox Plugin 0.7.0 and earlier allows attackers to connect to an attacker-specified host using attacker-specified username and password (perform a connection test), disable SSL/TLS validation for the entire Jenkins controller JVM as part of the connection test (see CVE-2022-28142), and test a rollback with attacker-specified parameters.

Why it matters now

EPSS 0.00544 45th percentileScored 2026-11-07
Fix Fixed org.jenkins-ci.plugins:proxmox (Maven): 0.7.1

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
JenkinsJenkins Proxmox Pluginup to 0.7.0—No fix listedCNA
—org.jenkins-ci.plugins:proxmox (Maven)before 0.7.10.7.1Patch availableGHSA-wjvr-2hjg-6rhj
  • Jenkins Proxmox Plugin VendorJenkins Affected up to 0.7.0 Fixed in — No fix listed CNA
  • org.jenkins-ci.plugins:proxmox (Maven) Vendor— Affected before 0.7.1 Fixed in 0.7.1 Patch available GHSA-wjvr-2hjg-6rhj

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:jenkins:proxmox:*:*:*:*:*:jenkins:*:*up to 0.7.0VulnerableJenkins
  • cpe:2.3:a:jenkins:proxmox:*:*:*:*:*:jenkins:*:* Versions up to 0.7.0 Vulnerable ·Jenkins

Remediation

  • Fix · GHSA-wjvr-2hjg-6rhj org.jenkins-ci.plugins:proxmox (Maven) Fixed in 0.7.1 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2022-28143
  2. 2026-10-03 Alias added: GHSA-wjvr-2hjg-6rhj

References

  • TI-2022-10940 Improper certificate validation in Jenkins Proxmox Plugin CVSS 3.1HIGH 7.5
  • TI-2022-10939 Insufficiently protected credentials in Jenkins Proxmox Plugin CVSS 3.1MEDIUM 6.5
  • TI-2022-10942 Missing authorization in Jenkins Proxmox Plugin CVSS 3.1MEDIUM 6.5

Sources