Read the docs
TI-2022-11364 Aliases CVE-2022-28730GHSA-ggjq-8c4c-68r5

Apache JSPWiki Cross-site scripting vulnerability on AJAXPreview.jsp

Priority HIGH 69CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
Required
Attack complexity
Low
Impact type
Cross-site scripting
Confidentiality · integrity · availability
Low · Low · None
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.

Summary

A carefully crafted request on AJAXPreview.jsp could trigger an XSS vulnerability on Apache JSPWiki, which could allow the attacker to execute javascript in the victim's browser and get some sensitive information about the victim. This vulnerability leverages CVE-2021-40369, where the Denounce plugin dangerously renders user-supplied URLs. Upon re-testing CVE-2021-40369, it appears that the patch was incomplete as it was still possible to insert malicious input via the Denounce plugin. Apache JSPWiki users should upgrade to 2.11.3 or later.

Why it matters now

EPSS 0.86157 99th percentileScored 2026-11-07
Fix Fixed org.apache.jspwiki:jspwiki-main (Maven): 2.11.3

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
ApacheApache JSPWikiApache JSPWiki – Apache JSPWiki up to 2.11.2—No fix listedCNA
—org.apache.jspwiki:jspwiki-main (Maven)before 2.11.32.11.3Patch availableGHSA-ggjq-8c4c-68r5
  • Apache JSPWiki VendorApache Affected Apache JSPWiki – Apache JSPWiki up to 2.11.2 Fixed in — No fix listed CNA
  • org.apache.jspwiki:jspwiki-main (Maven) Vendor— Affected before 2.11.3 Fixed in 2.11.3 Patch available GHSA-ggjq-8c4c-68r5

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:apache:jspwiki:*:*:*:*:*:*:*:*before 2.11.3VulnerableApache
  • cpe:2.3:a:apache:jspwiki:*:*:*:*:*:*:*:* Versions before 2.11.3 Vulnerable ·Apache

Remediation

  • Fix · GHSA-ggjq-8c4c-68r5 org.apache.jspwiki:jspwiki-main (Maven) Fixed in 2.11.3 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2022-28730
  2. 2026-10-03 Alias added: GHSA-ggjq-8c4c-68r5

References

  • TI-2022-10292 XSS vulnerability on XHRHtml2Markup.jsp in JSPWiki 2.11.2 CVSS 3.1MEDIUM 6.1
  • TI-2022-11366 Apache JSPWiki Cross-site scripting vulnerability on WeblogPlugin CVSS 3.1MEDIUM 6.1
  • TI-2022-11365 Apache JSPWiki CSRF in UserPreferences.jsp CVSS 3.1MEDIUM 6.5
  • TI-2024-17991 Apache JSPWiki: Cross-site scripting vulnerability on upload page CVSS 3.1MEDIUM 6.1
  • TI-2026-23006 Apache JSPWiki: UserManager does not sanity-check user database at startup CVSS 3.1CRITICAL 9.8
  • TI-2021-19841 Arbitrary file deletion on logout CVSS 3.1CRITICAL 9.1
See all 28 →

Sources