Read the docs
TI-2022-11366 Aliases CVE-2022-28732GHSA-hph8-29xw-qfxx

Apache JSPWiki Cross-site scripting vulnerability on WeblogPlugin

Priority HIGH 68CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
Required
Attack complexity
Low
Impact type
Cross-site scripting
Confidentiality · integrity · availability
Low · Low · None
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.

Summary

A carefully crafted request on WeblogPlugin could trigger an XSS vulnerability on Apache JSPWiki, which could allow the attacker to execute javascript in the victim's browser and get some sensitive information about the victim. Apache JSPWiki users should upgrade to 2.11.3 or later.

Why it matters now

EPSS 0.82827 99th percentileScored 2026-11-07
Fix Fixed org.apache.jspwiki:jspwiki-main (Maven): 2.11.3

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
ApacheApache JSPWikiApache JSPWiki – Apache JSPWiki up to 2.11.2—No fix listedCNA
—org.apache.jspwiki:jspwiki-main (Maven)before 2.11.32.11.3Patch availableGHSA-hph8-29xw-qfxx
  • Apache JSPWiki VendorApache Affected Apache JSPWiki – Apache JSPWiki up to 2.11.2 Fixed in — No fix listed CNA
  • org.apache.jspwiki:jspwiki-main (Maven) Vendor— Affected before 2.11.3 Fixed in 2.11.3 Patch available GHSA-hph8-29xw-qfxx

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:apache:jspwiki:*:*:*:*:*:*:*:*before 2.11.3VulnerableApache
  • cpe:2.3:a:apache:jspwiki:*:*:*:*:*:*:*:* Versions before 2.11.3 Vulnerable ·Apache

Remediation

  • Fix · GHSA-hph8-29xw-qfxx org.apache.jspwiki:jspwiki-main (Maven) Fixed in 2.11.3 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2022-28732
  2. 2026-10-03 Alias added: GHSA-hph8-29xw-qfxx

References

  • TI-2022-11364 Apache JSPWiki Cross-site scripting vulnerability on AJAXPreview.jsp CVSS 3.1MEDIUM 6.1
  • TI-2022-10292 XSS vulnerability on XHRHtml2Markup.jsp in JSPWiki 2.11.2 CVSS 3.1MEDIUM 6.1
  • TI-2022-11365 Apache JSPWiki CSRF in UserPreferences.jsp CVSS 3.1MEDIUM 6.5
  • TI-2024-17991 Apache JSPWiki: Cross-site scripting vulnerability on upload page CVSS 3.1MEDIUM 6.1
  • TI-2026-23006 Apache JSPWiki: UserManager does not sanity-check user database at startup CVSS 3.1CRITICAL 9.8
  • TI-2021-19841 Arbitrary file deletion on logout CVSS 3.1CRITICAL 9.1
See all 28 →

Sources