Insufficiently protected credentials in Dell Unity
Key facts
- Attack vector
- Local
- Privileges required
- High
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-256.
Summary
Dell Unity, Dell UnityVSA, and Dell Unity XT versions prior to 5.2.0.0.5.173 contain a plain-text password storage vulnerability when certain off-array tools are run on the system. The credentials of a user with high privileges are stored in plain text. A local malicious user with high privileges may use the exposed password to gain access with the privileges of the compromised user.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Dell | Unity | before 5.2.0.0.5.173 | 5.2.0.0.5.173 | Patch available | CNA |
- Unity VendorDell Affected before 5.2.0.0.5.173 Fixed in 5.2.0.0.5.173 Patch available CNA
CPE configurations NVD · 3
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:dell:unity_operating_environment:*:*:*:*:*:*:*:* | before 5.2.0.0.5.173 | Vulnerable | Dell |
| cpe:2.3:a:dell:unity_xt_operating_environment:*:*:*:*:*:*:*:* | before 5.2.0.0.5.173 | Vulnerable | Dell |
| cpe:2.3:a:dell:unityvsa_operating_environment:*:*:*:*:*:*:*:* | before 5.2.0.0.5.173 | Vulnerable | Dell |
- cpe:2.3:a:dell:unity_operating_environment:*:*:*:*:*:*:*:* Versions before 5.2.0.0.5.173 Vulnerable ·Dell
- cpe:2.3:a:dell:unity_xt_operating_environment:*:*:*:*:*:*:*:* Versions before 5.2.0.0.5.173 Vulnerable ·Dell
- cpe:2.3:a:dell:unityvsa_operating_environment:*:*:*:*:*:*:*:* Versions before 5.2.0.0.5.173 Vulnerable ·Dell
Remediation
- Fix · CNA Unity (Dell) Fixed in 5.2.0.0.5.173
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
Dell Unity 5.2.0.0.5.173
2 records Highest priority Priority MEDIUM 1 MEDIUM, 1 LOW
Other records, highest priority first
- TI-2022-11638 Missing brute-force protection in Dell UnityPriority MEDIUM 46
Timeline
- 2026-10-02 Threatist record created from CVE-2022-29085
- 2026-10-03 Alias added: GHSA-pgv4-5r2v-vqfp
References
More Dell Unity Operating Environment vulnerabilities
- TI-2025-24909 OS command injection in Dell Unity CVSS 3.1CRITICAL 9.8
- TI-2025-16296 OS command injection in Dell Unity CVSS 3.1CRITICAL 9.8
- TI-2024-33087 OS command injection in Dell Unity CVSS 3.1CRITICAL 9.8
- TI-2025-18126 OS command injection in Dell Unity CVSS 3.1CRITICAL 9.1
- TI-2022-11638 Missing brute-force protection in Dell Unity CVSS 3.1CRITICAL 9.8
- TI-2025-18125 OS command injection in Dell Unity CVSS 3.1HIGH 7.3
Sources
- CVE-2022-29085 · CVE Program
- CVE-2022-29085 · NVD
- FIRST EPSS
- GHSA-pgv4-5r2v-vqfp · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences