Cross-site scripting in Dell Unity
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-79.
Summary
Dell Unity, Dell UnityVSA, and Dell UnityXT versions prior to 5.2.0.0.5.173 contain a Reflected Cross-Site Scripting Vulnerability in Unisphere GUI. An Unauthenticated Remote Attacker could potentially exploit this vulnerability, leading to the execution of malicious HTML or JavaScript code in a victim user's web browser in the context of the vulnerable web application. Exploitation may lead to information disclosure, session theft, or client-side request forgery.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Dell | Unity | before 5.2.0.0.5.173 | 5.2.0.0.5.173 | Patch available | CNA |
- Unity VendorDell Affected before 5.2.0.0.5.173 Fixed in 5.2.0.0.5.173 Patch available CNA
CPE configurations NVD · 3
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:dell:unity_operating_environment:*:*:*:*:*:*:*:* | before 5.2.0.0.5.173 | Vulnerable | Dell |
| cpe:2.3:a:dell:unity_xt_operating_environment:*:*:*:*:*:*:*:* | before 5.2.0.0.5.173 | Vulnerable | Dell |
| cpe:2.3:a:dell:unityvsa_operating_environment:*:*:*:*:*:*:*:* | before 5.2.0.0.5.173 | Vulnerable | Dell |
- cpe:2.3:a:dell:unity_operating_environment:*:*:*:*:*:*:*:* Versions before 5.2.0.0.5.173 Vulnerable ·Dell
- cpe:2.3:a:dell:unity_xt_operating_environment:*:*:*:*:*:*:*:* Versions before 5.2.0.0.5.173 Vulnerable ·Dell
- cpe:2.3:a:dell:unityvsa_operating_environment:*:*:*:*:*:*:*:* Versions before 5.2.0.0.5.173 Vulnerable ·Dell
Remediation
- Fix · CNA Unity (Dell) Fixed in 5.2.0.0.5.173
Timeline
- 2026-10-02 Threatist record created from CVE-2022-29091
- 2026-10-03 Alias added: GHSA-h5xq-v95p-wq6m
References
More Dell Unity Operating Environment vulnerabilities
- TI-2025-24909 OS command injection in Dell Unity CVSS 3.1CRITICAL 9.8
- TI-2025-16296 OS command injection in Dell Unity CVSS 3.1CRITICAL 9.8
- TI-2024-33087 OS command injection in Dell Unity CVSS 3.1CRITICAL 9.8
- TI-2025-18126 OS command injection in Dell Unity CVSS 3.1CRITICAL 9.1
- TI-2022-11638 Missing brute-force protection in Dell Unity CVSS 3.1CRITICAL 9.8
- TI-2025-18125 OS command injection in Dell Unity CVSS 3.1HIGH 7.3
Sources
- CVE-2022-29091 · CVE Program
- CVE-2022-29091 · NVD
- FIRST EPSS
- GHSA-h5xq-v95p-wq6m · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences