Known or guessable hidden files may be accessed in Jupyter Server
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-200.
Summary
Jupyter Server provides the backend (i.e. the core services, APIs, and REST endpoints) for Jupyter web applications like Jupyter Notebook. Prior to version 1.17.1, if notebook server is started with a value of `root_dir` that contains the starting user's home directory, then the underlying REST API can be used to leak the access token assigned at start time by guessing/brute forcing the PID of the jupyter server. While this requires an authenticated user session, this URL can be used from a cross-site scripting payload or from a hooked or otherwise compromised browser to leak this access token to a malicious third party. This token can be used along with the REST API to interact with Jupyter services/notebooks such as modifying or overwriting critical files, such as .bashrc or .ssh/authorized_keys, allowing a malicious user to read potentially sensitive data and possibly gain control of the impacted system. This issue is patched in version 1.17.1.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| jupyterlab | jupyter_server | before 1.17.1 | 1.17.1 | Patch available | CNA |
| — | jupyter-server (PyPI) | before 1.17.1 | 1.17.1 | Patch available | GHSA-q874-g24w-4q9g |
| — | jupyter-server (PyPI) | 2.0.0a0 to before 2.0.0a1 | 2.0.0a1 | Patch available | GHSA-q874-g24w-4q9g |
- jupyter_server Vendorjupyterlab Affected before 1.17.1 Fixed in 1.17.1 Patch available CNA
- jupyter-server (PyPI) Vendor— Affected before 1.17.1 Fixed in 1.17.1 Patch available GHSA-q874-g24w-4q9g
- jupyter-server (PyPI) Vendor— Affected 2.0.0a0 to before 2.0.0a1 Fixed in 2.0.0a1 Patch available GHSA-q874-g24w-4q9g
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:jupyter:jupyter_server:*:*:*:*:*:*:*:* | before 1.17.0 | Vulnerable | jupyterlab |
- cpe:2.3:a:jupyter:jupyter_server:*:*:*:*:*:*:*:* Versions before 1.17.0 Vulnerable ·jupyterlab
Remediation
- Fix · CNA jupyter_server (jupyter-server) Fixed in 1.17.1
- Fix · GHSA-q874-g24w-4q9g jupyter-server (PyPI) Fixed in 1.17.1 Advisory →
- Fix · GHSA-q874-g24w-4q9g jupyter-server (PyPI) Fixed in 2.0.0a1 Advisory →
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2022-29241
- 2026-10-03 Alias added: GHSA-q874-g24w-4q9g
References
Advisory 2
Other 4
- https://github.com/jupyter-server/jupyter_server/commit/3485007abbb459585357212dcaa20521989272e8
- https://github.com/jupyter-server/jupyter_server/commit/877da10cd0d7ae45f8b1e385fa1f5a335e7adf1f
- https://github.com/jupyter-server/jupyter_server
- https://github.com/pypa/advisory-database/tree/main/vulns/jupyter-server/PYSEC-2022-211.yaml
More jupyterlab Jupyter Server vulnerabilities
- TI-2026-05842 CORS Origin Validation Bypass in jupyter-server CVSS 3.1HIGH 8.8
- TI-2026-04748 Path Traversal in jupyter/jupyter CVSS 3.1HIGH 8.1
- TI-2026-27533 jupyter-server path traversal allows access to sibling directories sharing root_dir name prefix CVSS 4.0HIGH 7.6
- TI-2025-38102 jupyter_server next parameter open redirect can redirect users to external domains CVSS 4.0MEDIUM 6.3
- TI-2026-32614 Jupyter Server: Stored XSS in `NbconvertFileHandler` / `NbconvertPostHandler` via missing `sandbox` CSP CVSS 4.0CRITICAL 9.3
- TI-2024-23252 Jupyter server on Windows discloses Windows user password hash CVSS 3.1HIGH 7.5
Sources
- CVE-2022-29241 · CVE Program
- CVE-2022-29241 · NVD
- FIRST EPSS
- GHSA-q874-g24w-4q9g · GitHub Advisory Database · CC BY 4.0
- CVE-2022-29241 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences