Remote code execution in Indy's NODE_UPGRADE transaction
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-287.
Summary
Indy Node is the server portion of a distributed ledger purpose-built for decentralized identity. In versions 1.12.4 and prior, the `pool-upgrade` request handler in Indy-Node allows an improperly authenticated attacker to remotely execute code on nodes within the network. The `pool-upgrade` request handler in Indy-Node 1.12.5 has been updated to properly authenticate pool-upgrade transactions before any processing is performed by the request handler. The transactions are further sanitized to prevent remote code execution. As a workaround, endorsers should not create DIDs for untrusted users. A vulnerable ledger should configure `auth_rules` to prevent new DIDs from being written to the ledger until the network can be upgraded.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| hyperledger | indy-node | up to 1.12.4 | — | No fix listed | CNA |
| — | indy-node (PyPI) | before 1.12.5rc1 | 1.12.5rc1 | Patch available | GHSA-r6v9-p59m-gj2p |
- indy-node Vendorhyperledger Affected up to 1.12.4 Fixed in — No fix listed CNA
- indy-node (PyPI) Vendor— Affected before 1.12.5rc1 Fixed in 1.12.5rc1 Patch available GHSA-r6v9-p59m-gj2p
Remediation
- Fix · GHSA-r6v9-p59m-gj2p indy-node (PyPI) Fixed in 1.12.5rc1 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2022-31020
- 2026-10-03 Alias added: GHSA-r6v9-p59m-gj2p
References
Advisory 3
More hyperledger vulnerabilities
- TI-2026-30139 ObjectInputStream.readObject() without ObjectInputFilter in fabric-sdk-java allows Java deserialization RCE CVSS 4.0CRITICAL 9.3
- TI-2024-14390 Hyperledger Aries Cloud Agent Python result of presentation verification not checked for LDP-VC CVSS 3.1CRITICAL 9.9
- TI-2022-13066 Unlinkability broken in ursa when verifiers use malicious keys CVSS 3.1MEDIUM 5.3
- TI-2022-16450 Incorrect Conversion between Numeric Types in Besu Ethereum Client CVSS 3.1CRITICAL 9.1
- TI-2025-21486 ALTBN128_ADD, ALTBN128_MUL, ALTBN128_PAIRING precompile functions do not check if points are on curve CVSS 4.0HIGH 8.7
- TI-2022-13165 Improper Input Validation in fabric hyperledger CVSS 3.1HIGH 7.5
Sources
- CVE-2022-31020 · CVE Program
- CVE-2022-31020 · NVD
- FIRST EPSS
- GHSA-r6v9-p59m-gj2p · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences