Improper Input Validation in fabric hyperledger
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub.
Summary
Hyperledger Fabric is a permissioned distributed ledger framework. In affected versions if a consensus client sends a malformed consensus request to an orderer it may crash the orderer node. A fix has been added in commit 0f1835949 which checks for missing consensus messages and returns an error to the consensus client should the message be missing. Users are advised to upgrade to versions 2.2.7 or v2.4.5. There are no known workarounds for this issue.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| hyperledger | fabric | before 2.2.7; 2.3.0 to before 2.4.5 | 2.2.7, 2.4.5 | Patch available | CNA |
| — | github.com/hyperledger/fabric (Go) | before 2.2.7 | 2.2.7 | Patch available | GHSA-72x4-cq6r-jp4p |
| — | github.com/hyperledger/fabric (Go) | 2.3.0 to before 2.4.5 | 2.4.5 | Patch available | GHSA-72x4-cq6r-jp4p |
- fabric Vendorhyperledger Affected before 2.2.7; 2.3.0 to before 2.4.5 Fixed in 2.2.7, 2.4.5 Patch available CNA
- github.com/hyperledger/fabric (Go) Vendor— Affected before 2.2.7 Fixed in 2.2.7 Patch available GHSA-72x4-cq6r-jp4p
- github.com/hyperledger/fabric (Go) Vendor— Affected 2.3.0 to before 2.4.5 Fixed in 2.4.5 Patch available GHSA-72x4-cq6r-jp4p
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:hyperledger:fabric:*:*:*:*:*:*:*:* | before 2.2.7; 2.3.0 to before 2.4.5 | Vulnerable | hyperledger |
- cpe:2.3:a:hyperledger:fabric:*:*:*:*:*:*:*:* Versions before 2.2.7; 2.3.0 to before 2.4.5 Vulnerable ·hyperledger
Remediation
- Fix · CNA fabric (hyperledger) Fixed in 2.2.7, 2.4.5
- Fix · GHSA-72x4-cq6r-jp4p github.com/hyperledger/fabric (Go) Fixed in 2.2.7 Advisory →
- Fix · GHSA-72x4-cq6r-jp4p github.com/hyperledger/fabric (Go) Fixed in 2.4.5 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2022-31121
- 2026-10-03 Alias added: GHSA-72x4-cq6r-jp4p
References
Advisory 4
More hyperledger Fabric vulnerabilities
- TI-2026-30139 ObjectInputStream.readObject() without ObjectInputFilter in fabric-sdk-java allows Java deserialization RCE CVSS 4.0CRITICAL 9.3
- TI-2022-22261 Hyperledger Fabric 2.3 allows attackers to cause a denial of service (orderer crash) by… CVSS 3.1HIGH 7.5
- TI-2022-16448 Remote denial of service in Hyperledger Fabric Gateway CVSS 3.1HIGH 7.0
- TI-2023-24774 Crosslinking transaction attack in hyperledger/fabric CVSS 3.1HIGH 7.1
- TI-2024-30320 Hyperledger Fabric through 3.0.0 and 2.5.x through 2.5.9 do not verify that a request has… CVSS 3.1MEDIUM 5.3
Sources
- CVE-2022-31121 · CVE Program
- CVE-2022-31121 · NVD
- FIRST EPSS
- GHSA-72x4-cq6r-jp4p · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences